How To Downgrade iTunes 10.5 and subsiquently the iOS5 beta

Discussion in 'Mac Apps and Mac App Store' started by ert3, Jun 12, 2011.

  1. ert3, Jun 12, 2011
    Last edited: Jul 14, 2011

    ert3 macrumors 6502a


    Dec 10, 2007
    If your like me you may have failed at trying the exploit for the iOS beta and decided that patients was a virtue.

    For those of you who upgraded to iTunes 10.5 and iOS 5 here is how to rescue your now overly expensive paper weight.

    First Uninstall iTunes

    Simply do this by removing iTunes from your application folder and deleting it (the trashbin should do just fine).

    Then Install iTunes 10.3

    (this should generate an error which i show you how to fix later)

    Now for the tricky part as your itunes library database has been upgraded to the iTunes 5 standard

    Go to ~/Music/iTunes/ (aka /user/[your user name]/Music/iTunes)

    Rename your [iTunes Library.itl] to [iTunes Library.bak] (DO NOT DELETE ANYTHING)

    Then go into the folder "Previous iTunes Libraries"

    There you will find a series of files with dates in their names the latest date was made when you upgraded your version of itunes and should have .itl on it while the others do not

    copy it into the parent folder ~/Music/iTunes/ and rename it [iTunes Library.itl]

    now run iTunes


    you can now downgrade your phone simply by using restore (though you may need to boot your phone in DFU mode) as iTunes 3 only lets you upgrade to version 4.3.3 anyway.

    I tested this myself and it works like a charm, all in all about 30 mins work given the speed of your computer.
  2. TOYSTRY, Jun 15, 2011
    Last edited: Jun 15, 2011

    TOYSTRY macrumors member

    Mar 30, 2011
    This didn't work......followed it to a "T". Any ideas?

    Here is my error:

    Process: iTunes [198]
    Path: /Applications/
    Version: 10.3.1 (10.3.1)
    Build Info: iTunes-10315501~1
    Code Type: X86 (Native)
    Parent Process: launchd [147]

    Date/Time: 2011-06-15 12:22:07.504 -0400
    OS Version: Mac OS X 10.7 (11A390)
    Report Version: 8

    Interval Since Last Report: 28235 sec
    Crashes Since Last Report: 11
    Per-App Crashes Since Last Report: 6
    Anonymous UUID: 7DF44008-DC10-4771-95D5-34FC9186E692

    Crashed Thread: 0

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000

    Application Specific Information:

    Dyld Error Message:
    Library not loaded: @executable_path/../Frameworks/iPodUpdater.framework/Versions/A/iPodUpdater
    Referenced from: /Applications/
    Reason: unsafe use of @executable_path in /Applications/ with restricted binary

    Binary Images:
    0x1000 - 0xe50ff3 (10.3.1 - 10.3.1) <DA5B3668-53FC-8550-A39C-06EB35AA692F> /Applications/
    0x8fe00000 - 0x8fe3320b dyld (195 - ???) <33A6763E-295E-3FE1-9594-81B9E296BACC> /usr/lib/dyld

    Model: iMac7,1, BootROM IM71.007A.B03, 2 processors, Intel Core 2 Duo, 2.4 GHz, 4 GB, SMC 1.21f4
    Graphics: ATI Radeon HD 2600 Pro, ATI,RadeonHD2600, PCIe, 256 MB
    Memory Module: BANK 0/DIMM0, 2 GB, DDR2 SDRAM, 667 MHz, 0x7F98000000000000, 0x393930353239352D3035352E4130304C4600
    Memory Module: BANK 1/DIMM1, 2 GB, DDR2 SDRAM, 667 MHz, 0x7F98000000000000, 0x393930353239352D3035352E4130304C4600
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x88), Broadcom BCM43xx 1.0 (
    Bluetooth: Version 2.5.0b13, 2 service, 19 devices, 1 incoming serial ports
    Network Service: AirPort, AirPort, en1
    Serial ATA Device: WDC WD3200AAJS-40VWA1, 320.07 GB
    Parallel ATA Device: OPTIARC DVD RW AD-5630A, 7.77 GB
    USB Device: Built-in iSight, apple_vendor_id, 0x8502, 0xfd400000 / 2
    USB Device: Keyboard Hub, apple_vendor_id, 0x1006, 0xfa400000 / 2
    USB Device: Apple Keyboard, apple_vendor_id, 0x0220, 0xfa420000 / 3
    USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x5d100000 / 2
    USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8206, 0x1a100000 / 2
  3. ert3 thread starter macrumors 6502a


    Dec 10, 2007
    sounds like you have a permissions error, try repairing permisions and or reinstall itunes

    please note if your using a 3rd party Java based download manager and not the one packed in with chrome firefox safari etc, your files might be corrupted as a result.

    try a re download/install and see if that gives you any help.

    I should probably also note that if you did not already have itunes 10.3.1 then its likely you will need to go through the entire uninstall process as described by apple
  4. lennon99 macrumors newbie

    Jun 29, 2011
    Where is my media?

    I did exactly what the instructions said, and iTunes 10.3 opens fine, but all my media is gone. How can I fix this? I have attached a picture of my iTunes music folder; thought it would help.

    Attached Files:

  5. Loeffler0425 macrumors newbie

    Oct 5, 2010

    Thanks man, This worked perfectly for me, appreciate it.
  6. jimmyc83 macrumors newbie

    Jun 21, 2010

    Worked a treat. The one problem I did have was that anything that I had purchased with 10.5 didn't appear in my library.

    One work around I came up with was transferring the purchased items off my iPad and iPhone, which seems to have worked (they both still running iOS 4.3.3, didn't put iOS 5 Beta on them).

    With the 'iTunes Library.bak' file, should that be left where it was or moved?
  7. GoKyu macrumors 65816


    Feb 15, 2007
    New Orleans
    Thanks so much, this helped me to downgrade back to 10.5 beta 2, because I accidentally installed beta 3 before upgrading the iPad... :eek:
  8. osio68 macrumors newbie

    Jul 13, 2011
    okay i couldnt find ~/Music/Itunes in the first place, but i did find everything else and i did find a folder called iTunes music...i did all the steps but it didnt work at all. It wont let the installation complete unless i "quit" itunes, which is installing the 10.3 and which i deleted the 10.5 already. please help! my iphone is a brick! and now my itunes is too! and i have like 5000 songs!
  9. osio68 macrumors newbie

    Jul 13, 2011
    Also i tried restoring on a different computer with itunes 10.3 and it still wont work. it still gives me error 1603. HELP!!!!
  10. applefanDrew macrumors 65816

    Jul 17, 2010
    Thanks a bunch! Glad to have commercial release iTunes on my computer again!
  11. osio68 macrumors newbie

    Jul 13, 2011
    Okay im having serious problems. and i need serious help but im afraid to go to the apple store. So i cant find and i dont knwo where to find the ~music/itunes or whatever folder (i know how to spell it when i can copy it but i cant see previous comments from here). Besides that, i followed all the directions perfectly except instead of moving the itunes library.itl into that folder i cant find i moved it to the Itunes music folder, which ifigured was the same. I also renamed the actual itl to bak like it asked. Now i have no itunes, a jumble of wrong folders, a brick of an iphone, and no help. all for this beta. i do no twant it anymore. HELP!
  12. ert3 thread starter macrumors 6502a


    Dec 10, 2007
    I would re authorize and just drag and drop the folder into itunes so it could make a new database

    i recommend keeping it just in-case but there is no immediate harm in deleting it

    I've updated the guide to make it easier to read see if this matches up with what you did.

    thats odd as a restore should force your iphone to restore but if your still having issues you can always bring it into the mac store (they aren't going to bite you for being a fanboy) or you can attempt a DFU restore
  13. luckymeeh macrumors newbie

    Mar 12, 2011
    Error: "iTunes cannot be deleted because it's required by OS X"

    For those of you who cannot move the app to your Trash can, do the following:

    1) Fire up Terminal
    2) Type: sudo rm -fdr /Applications/

    That's it. Close Terminal and install the older version.
  14. jeff526 macrumors newbie

    Apr 22, 2011
    Boston, MA
    Downgrade from IOS 5 Beta 4 to Beta 3

    Thanks for the post.

    I followed the instruction and successfully downgraded to iTunes Beta 3 and restored to IOS Beta 3 from Beta 4.
    However when I try to sync iTunes keeps saying I have an older SW on my iPhone installed and it will not sync.

    I tried reverting back to IOS 4.3.3 then upgrading to IOS 5 Betaa 3 and had the same issue.

    Any thoughts?
    I'm reliant on the new functionality and cannot go back to IOS 4.x
    However IOS Beta 4 is really buggy and I would love to go back to Beta 3

  15. JayDH macrumors 6502

    Jan 20, 2008
    Thanks!! Been looking for a solution to this. Now if I could only successfully downgrade to 4.3.5 from iOS beta 5... :(
  16. jshgambit macrumors newbie

    Mar 4, 2008

    Just started receiving "This copy of iTunes will expire in 110 hours." which caused me to start frantically looking for a solution to downgrade from 10.5 to 10.3. Hallelujah! for this thread! Thanks all!
  17. hovancu macrumors newbie

    Aug 17, 2011

    Thanks for sharing! Smooth and smart! :)

  18. xexus macrumors newbie

    Aug 27, 2011
    Error: "iTunes cannot be deleted because it's required by OS X"

    Error: "iTunes cannot be deleted because it's required by OS X"
    For those of you who cannot move the app to your Trash can, do the following:

    1) Fire up Terminal
    2) Type: sudo rm -fdr /Applications/

    That's it. Close Terminal and install the older version.

    hi i have lion on my computer and already did this steps but didn't work for me.
    its there another solution for this problem?
  19. isuquinndog macrumors newbie

    May 13, 2009
    Ok, so I am positive I did this. I uninstalled iTunes 10.5 and went back to 10.4.1 and I'm trying to now restore my iPhone back to 4.3.3 and it does the whole thing and then comes back with a 1015 error:

    The iPhone "iPhone" could not be restored. An unknown error occurred (1015).

  20. Sparky911 macrumors newbie

    Dec 17, 2011
    Does anyone know where I can get a copy of 10.4 for an iMac? I need it in order to connect to my media server. 10.5 does not work :(

Share This Page