How to get AirPlay (on a MBP 15") to display a perfect 1920x1080 picture on Apple TV?

betman

macrumors 6502
Original poster
Jan 15, 2013
260
2
Any ideas how I can get a 1920x1080 (no more, no less) picture displayed on my regular TV using Apple TV + AirPlay?

Every time I try I seem to get a picture that has some black bars on both or all sides...
 

paulrbeers

macrumors 68040
Dec 17, 2009
3,960
120
Any ideas how I can get a 1920x1080 (no more, no less) picture displayed on my regular TV using Apple TV + AirPlay?

Every time I try I seem to get a picture that has some black bars on both or all sides...
On the airplay menu, you need to use the "use Appletv ratio" or whatever rather than the MacBook Pro. Your TV will not have not have black bars but you will have black bars in the MacBook Pro. Unfortunately TVs are 16:9 and the MBP is 16:10 so one will end up with bars.
 

betman

macrumors 6502
Original poster
Jan 15, 2013
260
2
On the airplay menu, you need to use the "use Appletv ratio" or whatever rather than the MacBook Pro. Your TV will not have not have black bars but you will have black bars in the MacBook Pro. Unfortunately TVs are 16:9 and the MBP is 16:10 so one will end up with bars.
When turning on this feature in the toolbar on top of the screen I see that "Match Desktop Size To" is already set to Apple TV. Unfortunately I am still not using the full screen on my tv, with bars on all 4 sides.

Now in the top toolbar under the Airplay icon there is also the "Open Displays Preferences..." option. So in I go. :) There I instantly see "Optimize for" with "Apple TV (Airplay) selected. And underneath there are two options, "Best for Apple TV" and "Scaled." For some reason the second option has been chosen, with 1080p selected. So let's try to change this setting to "Best for Apple TV." To my surprise, nothing changes.

Could it be a setting on my tv that is causing this? I've toyed with settings like overscan or 1080p pixel direct but which have slightly increased the size of the picture, but there is still a black border on all four sides...
 

betman

macrumors 6502
Original poster
Jan 15, 2013
260
2
Instead of mirroring use the TV as a second display at its native resolution.
Unfortunately this made no difference and the picture still had black space on all sides.

But I just figured out what's going on. You need to go into the Apple TV menu and look for a setting that reads "Adjust for AirPlay Overscan." For some reason it's turned on by default. Turn it off and voila, everything is perfect. :)
 

betman

macrumors 6502
Original poster
Jan 15, 2013
260
2
Now that the picture is sorted I have another small issue to take care of: how do I make the taskbar disappear from the second screen (tv) when using the extended desktop option in AirPlay?

When I play something in full screen on my Mac the taskbar will hide, but on the extended desktop it just doesn't want to go away...
 

betman

macrumors 6502
Original poster
Jan 15, 2013
260
2
When I play something in full screen on my Mac the taskbar will hide, but on the extended desktop it just doesn't want to go away...
Anyone know how to make the top taskbar disappear from the extended desktop screen?
 

GlenK

macrumors 6502a
Aug 1, 2013
777
172
St. Augustine, FL
My biggest issue with ATV is anything I play on it is dark. Turned up the brightness on TV to almost the maximum and everything is still dark.

Any setting to help with this issue???

----------

Unfortunately this made no difference and the picture still had black space on all sides.

But I just figured out what's going on. You need to go into the Apple TV menu and look for a setting that reads "Adjust for AirPlay Overscan." For some reason it's turned on by default. Turn it off and voila, everything is perfect. :)
Where in settings is this located? I just looked through each settings menu and didn't see it. Thanks..
 

faffing

macrumors newbie
Oct 12, 2011
12
0
Thanks thanks re overscan tip, that had been driving me mad for months and I couldnt figure out a solution.

The setting cane be changed in Audio/Video in settings.

Tks again
 

Menneisyys2

macrumors 603
Jun 7, 2011
5,376
181
Thanks thanks re overscan tip, that had been driving me mad for months and I couldnt figure out a solution.

The setting cane be changed in Audio/Video in settings.

Tks again
You could consider following my AirPlay / HDMI / video playback-specific articles here at the MR forums. I published a lot of info on overscan (and the advantages of (dis)abling it) at http://forums.macrumors.com/showthread.php?t=1578989 a year ago. The AirPlay / ATV-specific section, also recommending this solution, is "1.2.3.3 Using AirPlay with the Apple TV".
 

matrix07

macrumors 603
Jun 24, 2010
5,026
1,519
Any ideas how I can get a 1920x1080 (no more, no less) picture displayed on my regular TV using Apple TV + AirPlay?

Every time I try I seem to get a picture that has some black bars on both or all sides...
I never have this. The default one fit right with ATV3 from my MacBook Air. I even have no need to adjust anything on ATV3 including overscan. The output picture is always perfect at 1920x1080.