How to get rid of "two-factor Authentication" nag screens?

7enderbender

macrumors 6502a
Original poster
May 11, 2012
511
11
North East US
Since the latest "update" my Mac and MacBook keep reminding in to "finish" two-factor authentication. I don't want it. I don't need it. How can I get rid of this? It's annoying and it seems to kick me out of my iCould and iTunes account occasionally it seems.
 

Fancuku

macrumors 65816
Oct 8, 2015
1,009
2,544
PA, USA
It was annoying me too and couldn't find a solution on how to block it. A couple of days ago I went ahead and turned the damn thing on. And it got even more annoying after that.
Then I turned it off on both, the iphone and my Macs and now am happy again. I haven't been asked since.
 

7enderbender

macrumors 6502a
Original poster
May 11, 2012
511
11
North East US
It was annoying me too and couldn't find a solution on how to block it. A couple of days ago I went ahead and turned the damn thing on. And it got even more annoying after that.
Then I turned it off on both, the iphone and my Macs and now am happy again. I haven't been asked since.

Thanks. Just did that on my iPhone, Macbook and Mac. Hope that does it. And I hope the kids and the wife didn't mess with anything on their devices...
 

DeltaMac

macrumors G3
Jul 30, 2003
9,795
2,442
Delaware
Open the setup for 2FA, then cancel.
Here's one way to do that:
System Preferences, then iCloud pane.
Click on Account Details.
When the account opens, click on the Security tab.
Click Turn On Two-Factor Authentication...
Then, important, click Cancel (don't continue, unless you really want to do this)
Click Done, then quit System Preferences. And, the little reminder will not return.
 
  • Like
Reactions: shape5

texasmccoy

macrumors member
Sep 24, 2010
36
5
Montgomery County, Texas
I had this same problem on my MacBook Air running OS High Sierra 10.13.3 ... here is what I did:
:apple: (apple icon at top of screen) > System Preferences > iCloud
This generated a window with a list of apps that can be shacked up with iCloud. At the very top of the list was the nagging notification about two-factor-authentication, with a "continue" button.
Hitting the continue button generated another small window with three options: turn on, learn more, and not now. I clicked the "not now" option, then "continue" button at the bottom of that window.
Voila! Nagging reminders about two-factor authentication and associated annoying red badge on my system preferences icon are all now gone, and I am happy.
You're welcome, everyone ;)
 

alzatron

macrumors newbie
Aug 19, 2007
18
5
How do I turn OFF the nag to set up two-factor authentication on iPhone? (I got the nag turned off on my Mac.)

I do not have, or want two-factor authentication. How can I make the reminder go away on iPhone?

This is showing up on my settings screen. Normally, I would just tap on this to see what happens but I'm afraid that might end up doing exactly what I don't want to do.
 

alzatron

macrumors newbie
Aug 19, 2007
18
5
How do I turn OFF the nag to set up two-factor authentication on iPhone? (I got the nag turned off on my Mac.)

I do not have, or want two-factor authentication. How can I make the reminder go away on iPhone?

This is showing up on my settings screen. Normally, I would just tap on this to see what happens but I'm afraid that might end up doing exactly what I don't want to do.
I can now answer my own question. The nag goes off by itself after about two weeks. I took no action whatsoever on my iPhone.
 

pMRa

macrumors newbie
Mar 27, 2018
1
0
Open the setup for 2FA, then cancel.
Here's one way to do that:
System Preferences, then iCloud pane.
Click on Account Details.
When the account opens, click on the Security tab.
Click Turn On Two-Factor Authentication...
Then, important, click Cancel (don't continue, unless you really want to do this)
Click Done, then quit System Preferences. And, the little reminder will not return.
Thank you so much: This is the one that has worked for me quite beautifully!
 

RocketSam

macrumors newbie
Jan 2, 2019
1
0
Washington, DC
I had this same problem on my MacBook Air running OS High Sierra 10.13.3 ... here is what I did:
:apple: (apple icon at top of screen) > System Preferences > iCloud
This generated a window with a list of apps that can be shacked up with iCloud. At the very top of the list was the nagging notification about two-factor-authentication, with a "continue" button.
Hitting the continue button generated another small window with three options: turn on, learn more, and not now. I clicked the "not now" option, then "continue" button at the bottom of that window.
Voila! Nagging reminders about two-factor authentication and associated annoying red badge on my system preferences icon are all now gone, and I am happy.
You're welcome, everyone ;)
This works perfectly, thank you!!! I am on Mojave 10.14.2 and there was one additional window after the "continue" option, and before the 3 options ("Turn On", "Learn More", and "Not Now"). So thankful that this worked as it really pissed me off that it showed up all of a sudden, AND it's so obnoxius. So thanks again!!!
 

MagnusVonMagnum

macrumors 603
Jun 18, 2007
5,165
1,380
Thank you so much: This is the one that has worked for me quite beautifully!
Didn't work here at all on Mojave. It seems Apple has plugged that "bug". It also seems Apple has been convinced two factor is the be-all end-all thing for force one everyone at some point. It is the most annoying security system I've ever seen since you need to have either email or a second device (phone, computer) on your person to login. I'm sorry, but I don't need to run upstairs to get my phone while downstairs watching Apple TV in my pajamas just to buy a damn movie. That's what the regular password is for. No one is going to come steal my Apple TV just to hack my account for THAT. Apple has gone overboard with security on things that don't need that level of protection. A bank? Yes. My TV? No.
 
  • Like
Reactions: Nermal

DeltaMac

macrumors G3
Jul 30, 2003
9,795
2,442
Delaware
If you have previously (or accidentally) enabled 2FA, I don't think it is possible to reverse that (and turn 2FA OFF) once you have enabled it.
But, do try calling AppleID support. They might have a method that you can use.
 

Nermal

Moderator
Staff member
Dec 7, 2002
18,733
1,205
New Zealand
Apple has gone overboard with security on things that don't need that level of protection.
And there have been bugs in it over the years as well. I don't know whether this is still possible, but at one point there was a certain sequence of steps that would make it prompt you for someone else's security questions.

The other thing that annoys me is that whenever Apple's system pops up a two-factor alert, it always says the account was accessed from a city about 200 km away. Advertisers manage to show ads for my specific town, but Apple and Google both just assume I'm in the country's biggest city. Why give a location at all, if it's flat-out wrong?
 

mjohnson24080

macrumors newbie
Feb 6, 2020
2
0
Now that it has switched from two step to two factor, it cannot be turned off. So these tricks do not work. I cannot get the nag screen to go away. In system preferences and where it says "finish setting up two factor" I click continue and it asks for my icloud password. I enter it and after a few seconds of the spinning wheel that box disappears and nothing happens. I've dug through numerous webpages to try to solve this and still can't. I'm fine with not turning off two factor, but I want that stupid pop up on my desktop to go away. When I click on account details and then click security it says it is on and has my phone number listed so I know it's set up. So I don't for the life of me understand why it says I need to finish setting it up. Please help!!
 

MagnusVonMagnum

macrumors 603
Jun 18, 2007
5,165
1,380
I just leave the red dot on the preferences. I'd rather see that than put up with two-factor, which I can't STAND, especially at home with Apple TV where my phone is upstairs on the other side of the house. It's not needed for such devices. And god forbid you lose your phone and didn't have a secondary option to restore it. It's a nightmare, IMO and all it did was change the hackers' tactics in how they go about things.
 

mjohnson24080

macrumors newbie
Feb 6, 2020
2
0
Yea I don’t mind the red dot in preferences, it’s just that stupid pop up on my desktop that I can’t get to go away. My Mac is slow as it is so having to open preferences to make it go away and then just exiting out every time is a pain because it takes forever. Then the next time I open my Mac the pop up is right back there again. Debating on just calling Mac support.
 

MagnusVonMagnum

macrumors 603
Jun 18, 2007
5,165
1,380
I don't have a pop up on the desktop, perhaps because I never activated two-step? The preference one came up on its own. The problem is in the future they may FORCE it down our throats. I keep trying to decide what is worse, Apple of Microsoft and it's absurd to think there's even a comparison.... (Microsoft keeps screwing up Windows 10 updates year after year too. I don't think there's any such thing as a stable desktop anymore. They keep trying to screw with stuff that isn't broken for some reason.)