How to install OS on VPC?

Discussion in 'Mac Apps and Mac App Store' started by mdeschenes, Apr 6, 2003.

  1. mdeschenes macrumors member

    Jan 31, 2003
    I have VPC 6.0 DOS and I cannot find the instructions on how to import my own copy of Windows 2000. I have downloaded the connectix (30 pages) instruction manual and read as much as I could decipher but could not find any clear explanation on how to do this. The manual seems to be designed for those versions of VPC that already have an OS installed.

    I would appreciate if someone could point me in the right direction regarding specific instructions on loading the OS from a CD. I tried the CD image thing. When going through the available files, those setup files on the CD were not highlighted and, therefore, could not be chosen for loading.

    If all else fails, I would hate to have to purchase VPC 6.0 with Windows installed for the outrageous price of over $400 cdn. Not when I have my own licensed copy of MS Windows.


    PS> yes, I know that there are probably other options that I could use other than VPC but I have several files from my old PC days that just do not translate well - I have already tried some of those programs.

  2. krohde macrumors member

    May 29, 2002
    Europe, UK
    the following should work:
    open VPC6 and open the list of pcs (apple key + L). then make a new pc and say that you want to create it using your CD which you have inserted in the CD-rom drive

    or if you have already installed DOS you can just tell it to go to the cdrom drive like this:

    when you are in the dos prompt:

    d: (D being the drive letter for your cdrom

    that should help a bit i think, otherwise let me know if we should try something else.

  3. mdeschenes thread starter macrumors member

    Jan 31, 2003
    Tried the d: thing but never received a prompt. Instead, the text message read "OS not found. Install an OS on this Hard Drive". When trying to install disk image from Windows 2000 CD, could not find a file to type into "Go To" window.
    The "SetUp exe" file was not "highlighted" so was unavailable to choose.

    Any more thoughts on the matter? We'll give it one more college try.

    If all else fails - For Sale... One copy of Windows 2000...

  4. MacsRgr8 macrumors 604


    Sep 8, 2002
    The Netherlands
    Is DOS running?
    If not, you should restart the Virtual PC with the the Windows 2000 CD inserted in the CD ROM. It should be a bootable CD ROM, so you should get the message "Type any key to boot from CD".
    Mind you, a hard drive image must be used for the PC environment. Otherwise there is nothing to install Windows on to.

    IT SHOULD WORK. I've done it many times.
  5. cubist macrumors 68020

    Jul 4, 2002
    Muncie, Indiana
    And I've done the D: thing. You set up a virtual machine with DOS. Make sure it boots to the C:\> prompt. Then, and only then, insert the W2K CD, and log over to the D: drive:
    (Your input shown in bold)
    It works very well, although very slowly.
  6. mdeschenes thread starter macrumors member

    Jan 31, 2003
    Thank you good people. The program is now up-and-running. However, I have another issue. I am trying to get Windows 2000 to recognize my modem. It will not. It offers a list to choose from that does not contain Apple's K56Flex and V.92 modem.

    Is there an equivalent that I can use? Is there a site offering this driver for PC?

    I guess using VPC will depend on resolving one issue after another.

  7. krohde macrumors member

    May 29, 2002
    Europe, UK
    i think it will work if you just click, in Win2000 prefs, the option that you share ethernet settings. otherwise there should be an option for sharing the modem under USB
  8. rickshaw macrumors newbie

    Feb 8, 2004
    similar problem

    I am having what appears to be the same problem as the previous poster mdeschenes but I do not understand the advice that seems to have helped him. I have installed the VPC and I get a screen that says "OS not found Install an OS on this hard drive". It does not seem to matter if I insert the Windows 2000 CD before or after opening the Virtual PC, I still get the same message. When using the "capture CD Image" option the windows boot files are not highlighted and unaccessible. I do not understand the advice that seemed to have helped the original poster, maybe because I have only used Macs and I don't know anything about windows or DOS. Anytime I try any of the suggested DOS commands in Virtual PC I get the same "OS not found Install an OS on this hard drive." Cubist previously wrote "You set up a virtual machine with DOS. Make sure it boots to the C:\> prompt." How exactly do I set up a virtual machine with DOS. Any help would be greatly appreciated.

Share This Page