How to keep secondary Monitor running while I close the MacBook Pro

Discussion in 'MacBook Pro' started by Greenhoe, Jan 16, 2009.

  1. Greenhoe macrumors regular

    Joined:
    Dec 17, 2008
    #1
    Hi,
    I have my Macbook Pro unibody hooked up to a 22 inch monitor which I run as my main screen, I would like to close my Mac Book Pro's lid since I have a keyboard and mouse hooked up to it and just run on my main screen but everytime I close the lid it goes into the sleep type mode and I don't know how to have it not do this. Thanks
     
  2. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #2
    You hook it all up, shut it, and then click the mouse or a key on the keyboard to wake it up while it is shut. It will only output to the external.
     
  3. Greenhoe thread starter macrumors regular

    Joined:
    Dec 17, 2008
    #3
    Doesn't Work

    Thanks, although I tried that and it doesn't work. Could it be my monitor? I'm using a 22 inch LG Monitor hooked up by DVI via Mini Display Port to DVI adapter.
     
  4. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #4
    That could be it. I have no experience with Mini DisplayPort. Sorry.
     
  5. Eddyisgreat macrumors 601

    Joined:
    Oct 24, 2007
    #5
    Make sure the magsafe adapter is plugged in and powered. You will not be able to run in clamshell mode on the battery without hacks to the OS.
     
  6. Greenhoe thread starter macrumors regular

    Joined:
    Dec 17, 2008
    #6
    I don't have it running on the battery, I have it plugged into the wall as I never run it off the battery since I don't go anywhere, but it still won't work. Thanks
     
  7. danny_w macrumors 601

    Joined:
    Mar 8, 2005
    Location:
    Austin, TX
    #7
    Do you have a bluetooth mouse and keyboard? If so you need to enable the bluetooth to wake the computer. I don't know exactly how, but I think it is in System Preferences somewhere.
     
  8. Greenhoe thread starter macrumors regular

    Joined:
    Dec 17, 2008
    #8
    Nope, I'm using the new apple wired keyboard and a logitech wired mouse.
     
  9. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #9
    Try restarting the computer and leave the lid closed during the entire boot process.
     
  10. eron macrumors 6502

    Joined:
    Dec 2, 2008
    #10
    1) Make sure display setting is set to "mirror", "clone".

    2)Close the lid. (It should sleep).

    3)Move mouse or external keyboard to wake it up from sleep.
     

Share This Page