How to make a new tab in Safari start in the address bar

Discussion in 'Mac Apps and Mac App Store' started by mikelong622, Jul 20, 2010.

  1. mikelong622 macrumors 6502

    Joined:
    Sep 29, 2006
    Location:
    St. Paul, Minnesota
    #1
    Forgive me if this is answered.

    I'm finding it slightly annoying that in Safari 5.0, whenever I hit CMD+T to open a new tab, my cursor automatically starts in the google search box on the web page, and not in the address bar. Not only that, but I can't simply hit SHIFT-TAB to go backwards to the address bar.

    I'm a designer, so I'm constantly using shortcuts, not only in my design programs, but also in Safari, iTunes, etc. It would be nice to see a fix for this, so I can keep my hands on the keyboard, and off of my mouse.

    Hopefully this doesn't make me seem super lazy, lol. :D
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    It works for me like it should. CMD+T opens a new tab and the address bar gets activated. I have installed Glims though, maybe that is the solution?
     
  3. mikelong622 thread starter macrumors 6502

    Joined:
    Sep 29, 2006
    Location:
    St. Paul, Minnesota
    #3
    That didn't seem to do it, but at least I discovered a nice new extension. I am going to try a fresh install of Safari 5. :(

    Edit: The fresh install of Safari didn't work either. Any suggestions? Or anyone else experiencing this problem? I'd like to think I'm not the only one with this.
     
  4. reubs macrumors 68000

    Joined:
    Jun 22, 2006
    #4
    I don't have any extensions installed, and Cmd+T opens right up with the address bar.
     
  5. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #5
    Reset Safari...

    Replace the Safari plist file

    Try another user account

    Reinstall Safari

    Reinstall the OS (no, don't do that!) ;)
     
  6. Rico87 macrumors newbie

    Joined:
    Aug 15, 2013
    #6
    Solved!!

    So, all you need to do to solve this is to change your New Tab preferences

    Safari>Preferences>General

    "New Windows open with:" and "New tabs open with:" from a specific URL to Top Sites.
     
  7. jrs22 macrumors 6502

    Joined:
    Aug 1, 2012
    #7
    I'm not the original poster, but I was annoyed by this behavior. I had "new tab open with home page" which is google, and it opened with the cursor in the search box. I set it to open with a blank page and now the focus is on the address bar.

    Thanks for the tip.
     
  8. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #8
    Well! Sometimes it is useful to resurrect a three year old thread!
     

Share This Page