how to make Mail show email address (not just name) in the “To” column?

Discussion in 'Mac Apps and Mac App Store' started by LizKat, May 17, 2014.

  1. LizKat macrumors 68040

    LizKat

    Joined:
    Aug 5, 2004
    Location:
    Catskill Mountains
    #1
    I’m running Mavericks on a mid-2012 MBP. Finally took the plunge and moved my data over there from a mid-2010 MBP running Lion. Maybe I had this problem before and maybe not, but anyway I have it now:

    Some of my incoming mail displays just my name, like Jane Doe or Doe Jane in the “to” column. I used to see Jane Doe janedoe@some.domain or just janedoe@some.domain and that is what I want now.

    I don’t want just my name showing up in the “to” column, I want AT LEAST the email address to which the mail was sent, if not also the name which actually matters far less. Like lots of people, I have multiple email addressses so I always want to see to which a mail was sent when I look at any of my mail messages.

    I’m using the “classic layout” preference for the viewing window but even if I don’t, I still have this problem.

    Turning on or off “smart addresses” doesn’t make any difference.

    Even when I put “all headers” as my viewing preference (which it certainly is NOT), I only see the “to” email address in the “X-apparently-to” field when the “to” column of a mail only displays my name.

    Is there some way to fix this display attribute as a default by using some terminal command? I always want to see the "to" email address in my mails.
     
  2. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #2
    Unchecking "Use Smart Addresses" should do exactly what you want. Not sure why that wouldn't be working for you. Perhaps a corrupt mail pref file somewhere?
     
  3. flynz4 macrumors 68040

    Joined:
    Aug 9, 2009
    Location:
    Portland, OR
    #3
    For me, "smart email address" does select full email addresses. It only shows in the actual opened emails (if I double click to open), and it also shows in the preview pane. The full email address never shows up in my list of emails.

    /Jim
     
  4. LizKat thread starter macrumors 68040

    LizKat

    Joined:
    Aug 5, 2004
    Location:
    Catskill Mountains
    #4
    Shouldn't be the case (I did not migrate any setups, for instance, and the inbox content I was looking at when I noticed the problem was fresh off the server). But "shouldn't" and "isn't" are two different things, I realize that, so thanks for the suggestion.

    Hmm. I do usually see the email address in the list, as long as I have smart addressing turned off. I am starting to wonder if it's related somehow to the sender's contact display order or smart addressing preference. Anyway you're right that I can always see the "To" email address inside the mail if I open it. I noticed one bizarre thing while checking that out. In a couple of cases the list shows to "Doe Jane" but in the message interior the name order is switched so it says it's to "Jane Doe janedoe@some.domain". Someone's contact preferences must be driving the bus for that to happen. Mine, or the sender's?

    Anyway thank you both for the replies. I might have to live with the list view not always giving me what I want!
     

Share This Page