How to stop IOS10 from downloading all my albums?

Discussion in 'iOS 10' started by treehorn, Sep 16, 2016.

  1. treehorn macrumors 6502

    treehorn

    Joined:
    Aug 21, 2007
    #1
    I am finding the IOS10 upgrade to be...annoying as all get out when it comes to music.

    Main problem is that I can not get it to stop downloading songs/albums I have purchased from ITunes. Even though the ITunes Store preference/settings is set to not download purchases, and even though the music settings are set to not show Apple Music, it keeps downloading song after song, which I have deleted multiple times. In the space of typing this question, it's already downloaded an additional 452MB of music...

    I also hate that in order to get purchased albums to stop appearing in my library on my IPad, I have to download them one by one...and I have hundreds...

    I wish I could go back to 9...this is insane...

    Any advice on how to get some sanity back?
     
  2. Jal217 macrumors regular

    Jal217

    Joined:
    Oct 28, 2015
    #2
    The setting in music is a minimum to download. If you have "optimize storage" on in the music section, it'll still download music while there's free space, try turning that off
     
  3. treehorn thread starter macrumors 6502

    treehorn

    Joined:
    Aug 21, 2007
    #3
    I don't see that as an option in the Music option of the Settings window.

    I ended up deleting every album to make it stop...
     
  4. Lappen71 macrumors regular

    Lappen71

    Joined:
    Nov 16, 2012

Share This Page