How to stop "TM" expanding into ™??

Discussion in 'Mac Basics and Help' started by Cassady, Mar 17, 2016.

  1. Cassady macrumors 6502a

    Cassady

    Joined:
    Jul 7, 2012
    Location:
    Sqornshellous
    #1
    Hello all.

    I've basically given up on this now, and have resorted to hitting CMD+Z each time it happens. But it still annoys the daylights out of me.

    I often refer to TIMEMACHINE backups, and would prefer to type "TM" instead, as opposed to ™...

    But the hoops I have to jump through, to get OSX/iOS to stop doing that for me, automatically, is getting ridiculous.

    My attempts to purge it as a text shortcut option from my MBP/Mini/iPP/iPhone appears to be pointless. Its ghost simply returns, to mock me.
    I'm not even presented with the little floating menu with "x" option on a regularly consistent basis. Windows tricks of leaving leading spaces, and going back to change it after the replacement has happened, sometimes works, but not enough.

    My trick to get the title to present as expected involved CMD+Z after the 1st instance, but didn't work in the main body of this post. The ™ above >>>>>>>>>>> I give up.
     
  2. Mr_Brightside_@ macrumors 68020

    Mr_Brightside_@

    Joined:
    Sep 23, 2005
    Location:
    The 6ix
    #2
    System Prefs - Keyboard - Text

    Settings - General - Keyboard - Shortcuts
     
  3. Cassady thread starter macrumors 6502a

    Cassady

    Joined:
    Jul 7, 2012
    Location:
    Sqornshellous
    #3
    Done that. Ages ago. The 'included-by-default' TM shortcut is no longer to be found there. Deleted. Might work for a bit - but inevitably, it returns.

    Cannot say how long it takes before returning, since TM is not something I type *that* regularly, so not something I'm actively monitoring.

    I'm typing this on my iPhone, and for now, it's leaving me in peace: TM.

    But it has before, only to return. Going to submit this now, and type a follow-up post on my Mac, and see what happens.
    --- Post Merged, Mar 17, 2016 ---
    ™ ™ ™ .

    [head banging on desk].

    Just opened Prefs/Keyboard/Text to check again - it's NOT there. So I'm at a loss to explain where the trigger is coming from...
     
  4. chown33, Mar 17, 2016
    Last edited: Mar 17, 2016

    chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #4
    The feature you're running into is called "text replacement" or "text substitution".

    The control for it has moved around in different OS X versions. What's your OS version?

    See here for some info:
    https://support.apple.com/kb/PH18439?locale=en_US
    https://support.apple.com/kb/PH18434?locale=en_US&viewlocale=en_US

    Also try googling for:
    os x text replacement
    os x text substitution


    Do you have any keyboard macro apps installed?

    Does the problem occur in every app, or only one? Which ones?

    Do you have syncing between your devices?
    Turn it off, see if the problem stops propagating.
     
  5. Cassady thread starter macrumors 6502a

    Cassady

    Joined:
    Jul 7, 2012
    Location:
    Sqornshellous
    #5
    El Capo, whatever the latest version is.
    Have Textexpander, use it extensively. Verified that it's not there. In fact, I specifically inserted a snippet to allow for an expansion into same, on the odd occasion that I need to write about trademarks.

    What I surmise is happening is that somewhere, one of my devices is not downloading the newly set preferences settings (in OSX/iOS), after having removed it - only to then re-populate the rest with it again...

    But to track down the culprit is besting me at the moment.

    And yes, appears to be happening system-wide, wherever I can input text.
     
  6. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #6
    Just to clarify, so if you remove it from the text shortcuts, that fixes it... and the only issue it that it keeps coming back??

    So the problem is stopping it from coming back. I was having the same problem with El Capitan and turning iCloud Drive off then back on fixed it. There is a long thread here with people having the same issue.

    I think what is happening is when you delete the shortcut, it is still remaining in iCloud, then at some point getting synced back to your computer from iCloud.
     
  7. Cassady thread starter macrumors 6502a

    Cassady

    Joined:
    Jul 7, 2012
    Location:
    Sqornshellous
    #7
    Appreciate the link - pretty sure that's the problem, thanks.

    Your linked thread ends with a post referring to a blog, and in there, one of the comments (by a 'Scott') has a solution to the Zombie text-replacement bug.

    Quite a process, but appears to work. Will give it a try when next I have an afternoon off!
     
  8. drumcat macrumors 6502

    drumcat

    Joined:
    Feb 28, 2008
    Location:
    Otautahi, Aotearoa
    #8
    As an aside, the default keeps coming back... it might not if you renamed the trigger string... for example, make [tm] into [zztm] and save it as such. It's unlikely it would ever bother you again.
     
  9. Cassady thread starter macrumors 6502a

    Cassady

    Joined:
    Jul 7, 2012
    Location:
    Sqornshellous
    #9
    I saw this as a possible suggestion, and was considering giving it a go - might as well, less hassle if it works. The replies over at the other thread suggest that since this (in my particular case) was/is a default iOS/OSX(?) snippet, that changing it, will eventually see the 'original' return when the iCloud bug pulls through...

    Regardless, will give it a go, and see what happens. If it works, great. If not - I'll go the other route.
     

Share This Page