How to upgrade iMovie to 1.10 without updating your iPhone 4 to 4.1

Discussion in 'Jailbreaks and iOS Hacks' started by Norcalchavo, Sep 12, 2010.

  1. Norcalchavo macrumors regular

    Joined:
    Sep 17, 2007
    Location:
    Santa Clara, California
    #1
    Saw this on a different site and wanted to share:

    Only works for jailbroken users that are on 4.0 or 4.0.1.

    1. Get/Purchase iFile (you can use SSH too).

    2. Go to /System/Library/CoreServices.

    3. Locate the file called "SystemVersion.plist" and just tap it once.

    4. Press the "Edit" button in the upper left.

    5. If you are on 4.0 edit the "8A293" to "8B117", if you are on 4.0.1 change the "8A306" to "8B117".

    6. If you are on 4.0 edit the "4.0" string to "4.1", if you are on 4.0.1 change the "4.0.1" to "4.1".

    7. Now press "Done" on the upper right.

    8. Reboot (Respring doesn't work), and install the new iMovie from iTunes

    http://www.ipodtouchfans.com/forums/showthread.php?t=310552
     
  2. MACis122 macrumors regular

    Joined:
    Jun 6, 2010
    #2
    is it possible to get this through installous, i paid for the app originally just think it may be a easier solution
     
  3. Norcalchavo thread starter macrumors regular

    Joined:
    Sep 17, 2007
    Location:
    Santa Clara, California
    #3
    it's probably more trouble to go through installous, this tweak only took me less than a minute to do.
     
  4. Brannon macrumors regular

    Joined:
    Nov 28, 2009
    #4
    Worked beautifully!! I was considering loosing my jailbreak jus cuz i wanted iMovie so freakin bad! And there does not seem to be any issues with any other apps not functioning properly!

    Though i had to do a hard restart (DFU) to get it out of safe mode but it is running perfectly!

    I love the new iMovie app! this is what the first one should have been!

    Very helpful tip for any other updates in the future to that depend on the latest software version!

    Thank you!
     
  5. pujols617 macrumors member

    pujols617

    Joined:
    Jun 29, 2010
    #5
    What were to happen when you do upgrade to 4.1 (Post-JB Release of course) and future updates. Could this have an adverse effect on them?
     
  6. mphayvanh macrumors member

    Joined:
    Aug 16, 2010
    #6
    Tried it and Infinidock stopped working. Changed it back and all is fine. The new version of iMovie still works minus the icon (shows a blank white icon on Springboard).

    Side note: I still hate the fact it needs Location Services to work!
     
  7. nednarm macrumors 6502

    Joined:
    Apr 26, 2010
    Location:
    U.K
    #7
    Sweet! Works perfectly, thanks for the tut man.
    Edit: you have to change the strings back to what they were before after installing imovie. It tries to remove a bunch of packages in cydia otherwise.
     
  8. newrazr macrumors member

    Joined:
    Aug 8, 2010
    #8
    Any idea if this will also work to allow my Facetime chat between the new iPod Touch and a JB iP4?
     
  9. mytakeontech macrumors 6502a

    Joined:
    Jun 14, 2010
    #9
    Thanks for the tip! I was wondering why Cydia trying to uninstall so many packages when I tried to upgrade lockinfo.


    EDIT: Okay, after reverting back the iOS version from 4.1 to 4.0.1, my iMovie icon has turned white! :D

    I opened it and checked. Looks like it is working fine. I don't use iMovie that much so I am not worried!
     
  10. alne macrumors newbie

    Joined:
    Jul 12, 2010
    #10
    Yep the same thing - white icon. Anybody know how ti change it back to normal icon?
     
  11. james92se macrumors 6502a

    Joined:
    Jun 21, 2010
    Location:
    Dallas, TX
    #11
    What does iMovie 1.10 add/update?

    I just updated using this tutorial (thanks btw)

    Just wondering what this update adds. I've only really used iMovie once or twice to make a little vacation video earlier in the summer and I found it pretty hard to use and couldn't figure half of the features out and haven't used it since.

    I just might if this update make it a bit easier/clearer to use
     
  12. Norcalchavo thread starter macrumors regular

    Joined:
    Sep 17, 2007
    Location:
    Santa Clara, California
    #12
    Split video clips
    Automatic music looping when video extends beyond the music track
    In-app page of tips
    Support for the new fourth-generation iPod touch
     
  13. james92se macrumors 6502a

    Joined:
    Jun 21, 2010
    Location:
    Dallas, TX
    #13
    Wow, that would really help. I spent FOREVER trying to get my video clips "lined up" exactly with the end of my music on the video I made earlier in the summer.
     
  14. TJone macrumors 6502a

    Joined:
    Aug 2, 2010
    #14
    Great post. Thanks a lot - that worked great for me too. iMovie was in desperate need of an update and was lacking in those features.
     
  15. TJone macrumors 6502a

    Joined:
    Aug 2, 2010
    #15
    Just a warning - this worked great and allowed me to get the iMovie update. Then I opened Cydia and all of a sudden my Activator, SBSettings and Lockinfo was no longer displaying and not showing as installed and when I tried to install it gave me an error message about conflicts/dependencies. It took me a while to figure out but since Cydia saw the firmware as 4.1 it seemed to no longer be compatible with those apps and I was not able to reinstall. I had saved a copy of my original plist and reverted back just now and I was able to install everything once again and iMovie still works well. So save a copy of your plist so you can go back to it if needed. It took me a while to figure this out but I am not the sharpest knife...
     
  16. aelalfy macrumors 6502a

    Joined:
    May 2, 2010
    Location:
    Berlin, Germany
    #16
    Hey,

    Yea I nted to come back to this thread and edit it, the only problem I had was cydia wanting to remove my PDF patch from saurik. So I had to go back into the plist and setting it back to 4.0.1 after installing iMovie.

    I think it's important to add that in this thread so people don't lose packages

    Thanks
    AE
     
  17. Rooftop voter macrumors 6502a

    Joined:
    Jan 26, 2010
    #17
    Thanks, this worked like a charm. One thing to mention for me though, after I changed what needed changing, I couldn't get into the settings menue without the phone crashing. I had to go back into ifile and change the strings back. After that everything was ok again. Just thought I'd give a heads up.
     
  18. Norcalchavo thread starter macrumors regular

    Joined:
    Sep 17, 2007
    Location:
    Santa Clara, California
    #18
    Anyone figure out how to get back the original icon instead of the white icon?
     
  19. mphayvanh macrumors member

    Joined:
    Aug 16, 2010
    #19
    I read if you install the Installous version it will restore the icon. I haven't done it because I bought mine and don't care to pirate it.
     
  20. TJone macrumors 6502a

    Joined:
    Aug 2, 2010
    #20
    I tried replacing the icon@2x.png file in the iMovie folder but it did not help. It is still white which is strange. The correct @2x icon was in the folder but it is not loading it anymore for some reason. I may just try changing it in a Winterboard theme instead.
     

Share This Page