HTML Rendering Problems with Safari

Discussion in 'Mac Apps and Mac App Store' started by garybooberry, May 24, 2004.

  1. garybooberry macrumors member

    Jan 16, 2004
    Annapolis, MD
    Hi folks.

    I've been having a problem with the HTML rendering machine in Safari for a couple of months now, and it has gotten to the point of getting on my nerves enough to fix it. :D

    I'm running OS X Panther (10.3.3) on a 1.25 G4 MDD. Here's what happens:

    Upon first launching Safari (from a restart, or cold boot) Safari will show pages like this:


    It does not matter what page it is, but I usually visit here first when I start surfing, so there you go. The text is all Klingon in appearance. Shutting Safari down and restarting it solves the problem.

    This also affects Mail sometimes, but very rarely (as I assume Mail uses Safari's rendering machine for HTML e-mails).

    Here is what I have done to try and remedy this:

    1. Repaired permissions.
    2. Reset Safari
    3. Re-Installed Safari
    4. Checked language preferences in Safari - all OK.

    I assume the last thing to do is to remove Safari and do a clean install - but I'm looking for suggestions! :confused:

    Many thanks - Gary
  2. Sun Baked macrumors G5

    Sun Baked

    May 19, 2002

    Rarely have problems with the rendering here, but I'm not using Safari.

    I just get stuck with the rest of Mozilla's bugs, like the problems at the sites trying to get around the pop-up blocker.
  3. garybooberry thread starter macrumors member

    Jan 16, 2004
    Annapolis, MD
    I really do love the browser, it just seems silly to have to restart the app every time i use it for it to display text properly.

    Picky, picky, picky. :p
  4. superbovine macrumors 68030


    Nov 7, 2003
    funny, the little picture of the bug in the top right hand corner of your safari would indicate this is a hoax right :p
  5. johnnyjibbs macrumors 68030


    Sep 18, 2003
    London, UK
    You definitely have all your encoding set to Western, right? Strange. And yes, Panther does use Safari's rendering engine. (BTW the bug can be activated using the View menu and is a shortcut to inform Apple of any website incompatibilities).
  6. James L macrumors 6502a

    Apr 14, 2004
    No hoax... the first version(s) of Safari had that, it was an instant "submit a bug to apple" link when you found rendering problems. I am pretty sure that there is still a link to this under a menu.

    The other thing this shows me is that you are using an older version of safari. I would do a finder search for absolutely EVERYTHING bearing the name Safari and COMPLETELY delete it. DO another search to be sure.

    Then, perform a software update from the Apple menu to reinstall the latest version.

    I am a web designer, professionally, and have found Safari to have one of the best rendering engines out there.


  7. johnnyjibbs macrumors 68030


    Sep 18, 2003
    London, UK
    He's using the current version of Safari becasue the reload button points in a clockwise direction. Prior to 1.2 (ok now we're on 1.2.1 but..) this went in an anti-clockwise direction. The bug icon is easily activated from the view menu.
  8. garybooberry thread starter macrumors member

    Jan 16, 2004
    Annapolis, MD
    Encoding is definitely set to Western.

    Running Safari 1.2.1

    Helvetica Fractions fonts removed (suggested as a fix over at Apple Discussions).

    Times Roman (suggested by Apple's FAQ database).

    Cache removed (do it all the time).

    Cookies removes (do it all the time).

    History reset (do it all the time).

    Safari reset.

    Starting to look like I am yanking it and starting from scratch, eh?


    Thanks guys, :D
  9. wrldwzrd89 macrumors G5


    Jun 6, 2003
    Solon, OH
    Maybe Safari's encoding preferences are corrupted, even though they appear correct? To test this, remove Safari's preference file (found at [Your User Directory]/Library/Preferences/ from its folder and relaunch Safari so it creates a new file. If the problem's gone now, you can delete the old preference file. If it persists, the preferences were not the cause, so you can put them back.

Share This Page