I can't delete an individual file my time machine back up because I don't have permission to modify

Discussion in 'OS X El Capitan (10.11)' started by cupcakes2000, Dec 6, 2015.

  1. cupcakes2000 macrumors 6502

    Joined:
    Apr 13, 2010
    #1
    Hi,



    I have a problem. Osx 10.11.2 Beta (15C48a) has told me it has detected a problem on my time machine disk, and that I need to reformat it. So I have been trying to troubleshoot the issue.



    I wanted to (obviously) move my time machine backup bundle to a new disk, so I can trouble shoot the old.



    I tried this, but 7 hours in to a 33 hour transfer, I received an error, something like:



    'untitled 4.jpg already exists here'.



    I can't remember it, and I didn't screen shot it, but it was essentially that.



    With difficulty, I hunted down the offending item, and it was in Mobile Documents, within the library folder. A ridiculously difficult folder to even find, let alone access.



    I did however, and I deleted the offending item. As it was the back up that appeared to be the problem, I went into time machine (the 'star wars' mode), and tried to delete the ffending file using a right click delete etc.



    However, I got this message:



    'Some files can’t be processed, either because you don’t have permission to modify them, or because they are on a locked volume.'



    This is the problem. I can't seem to delete these files at all. I'm the administrator of the computer, as in, it's my personal machine. Why don't I have permission for this?



    I have tried from within finder, and I get the same message. I'm not great with Terminal, but i have tried a few commands found via Google, and still nothing works.



    I haven't written everything I have tried down here I have been at it for days, but I am open to any suggestions!



    Thanks!
     
  2. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #2
    I suspect that you tried to copy the Time Machine backup manually in Finder? You should never do this. Time Machine is based on an extensive number of symbolic links that Finder will not always correctly apply. That is why you should use the Time Machine application to manage it.

    Use Disk Utility to create a disk image of your Time Machine backup (select the Time Machine partition in the sidebar in Disk Utility then select File > New > "New Disk Image From [name]...". Alternatively, create a new partition and 'restore' your Time Machine partition on it, or simply use the new partition for a Time Machine backup and use the old one for analysis.

    Generally, when you receive that message then there is not much you can do. You can save your old backup on another partition or disk image, but a new Time Machine backup will probably be necessary anyway.
     
  3. cupcakes2000 thread starter macrumors 6502

    Joined:
    Apr 13, 2010
    #3
    I hadn't tried that! Thanks! I just did though, and I got:

    'The operation couldn’t be completed. (com.apple.diskutility error 3.)'
     
  4. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #4
    Have you performed a first-aid operation on it?
     
  5. cupcakes2000, Dec 6, 2015
    Last edited by a moderator: Dec 6, 2015

    cupcakes2000 thread starter macrumors 6502

    Joined:
    Apr 13, 2010
    #5
    Several times yes, I'm actually currently doing it again right now, I'll try the disk image thing again when it's complete..

    It's failed, again. Advising me to back up, but obviously I know that! Still wont create an image. Hmm.

    aha, my paranoia was making me check the 'read and write' box for creating the image. I tried it by leaving it on the default 'read only' , and it's creating it. I imagine it will take a few days though! Thank you for this advice. I didn't know this was the correct way of moving a TM backup.
     
  6. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #6
    I think read-only and compressed should both work. But if the filesystem itself is corrupted then this process might fail. The only alternative in such a case would be to create a second TM partition and use that one for a new backup. You can use the old partition for analysis or backup and delete it after you are done. It's usually a good idea to have two Time Machine backups on separate disks, in case one drive (or partition) fails.
     
  7. cupcakes2000, Dec 6, 2015
    Last edited: Dec 6, 2015

    cupcakes2000 thread starter macrumors 6502

    Joined:
    Apr 13, 2010
    #7
    The disk is contained with in a Lacie Quadra enclosure, I have a desktop manager utility that tells me that the disks within the system are 'ok', so I suspect it is a file system problem.

    I can access time machine like normal, although it wont back up, and I cant delete the thing in the original post, so it makes me wonder if the actual bundel is ok, just the actual formatting of the disk that is somehow the problem. I'm not even sure if that's possible, but I desperately want to retain my long time machine history. It helps me out a lot!

    I do normally have a weekly back up of my time machine, but that disk failed a few days ago. I need to wait a couple of weeks for my funds to replace it. This is why this is so important!!

    Also, the time machine itself is part of a raid mirror, it's a bit of extra back up in case one of the disks goes.
     
  8. cupcakes2000 thread starter macrumors 6502

    Joined:
    Apr 13, 2010
    #8
    Creating a disk image worked! Thank you for the advice! :)
     

Share This Page