I can't figure out how to download SD movies in ios 7

Discussion in 'iOS 7' started by davidwarren, Apr 13, 2014.

  1. davidwarren, Apr 13, 2014
    Last edited: Apr 14, 2014

    davidwarren macrumors 6502a

    Joined:
    Aug 28, 2007
    #1
    This is on an iPad mini.

    I am trying to put movies purchased in HD onto my ipad in SD. I have tried to re-download on my computer in iTunes from the purchased section, deselected "download on HD when available," selected prefer standard definition in iTunes settings, selected "prefer standard definition movies" in the iPad sync settings- no avail.

    I have tried to download from purchases on the iTunes app on the iPad, and they only show a "watch" button, not a download or download from the cloud button.

    I have tried to go to the movie on the iTunes App Store, it does show the HD/SD button, but only a "watch" button, no download or icloud button. Hitting "watch" only shows the HD version.

    Has anyone been able to load SD movies in ios 7???

    I don't know why this simple task is so difficult. I am hoping someone can tell me I am an idiot and it's a super simple thing I am just missing.


    EDIT for update: I was able to download the SD versions by signing out of itunes, killing the itunes app, and then going to the movie I wanted to download, and "purchase" it in SD. Once you are prompted to log in, itunes will say you have already purchased and would you like to download. It's a PITA, but it works.
     
  2. davidwarren thread starter macrumors 6502a

    Joined:
    Aug 28, 2007
    #2
    just for additional info, my other iPad mini is still on iOS 6, and the iTunes app allows for the selection of HD or SD, and you can download it. No problem. In iOS 7, there is no download option, only "watch."
     

Share This Page