I cant host in Warcraft Three

Discussion in 'Games' started by Drakek, Sep 5, 2005.

  1. Drakek macrumors newbie

    Jan 9, 2005
    Ok, Heres the problem I can't host. I don't have a router and I have the firewall that comes with Mac OS X. I've tried opening the port but it does nothing and if this is whats wrong I have an Airport. :confused: Ive tried everything from turning off my firewall to swithing to ethernet connections. If you can solve this thanks.
  2. kainjow Moderator emeritus


    Jun 15, 2000
    Are you behind a school/work/etc network or anything like that?
  3. ijimk macrumors 6502a


    Jun 17, 2004
    this is a common problem in WC3 i have this problem too, and i do think its mostly a firewall issue.
  4. aquanutz macrumors regular

    May 9, 2005
    Boston, MA (I miss Willoughby, Ohio)
    If you are on a school network, good luck with having the admin's open up the ports for your, but if you are on a home network with a router, go into it and port forward port: 6112 TCP to your IP address and you should be fine. I currently have it done on my network here and it works fine.
  5. Soulstorm macrumors 68000


    Feb 1, 2005
    Just disable your firewall that came with your mac and you should be just fine. I have the same problem when hosting with firewall.
  6. Drakek thread starter macrumors newbie

    Jan 9, 2005
    I don't know how to disable besides clicking the off button in the system preferences and I've done that oh yeah I am on a home computer I just cant get it to work a more detaled way might help.
  7. QCassidy352 macrumors G4


    Mar 20, 2003
    Bay Area
    I have the same problem, as does my brother, and neither of us is behind a firewall. It's really annoying, and I haven't been able to figure out a way around it...
  8. goodtimes5 macrumors 6502a


    Apr 4, 2004
    Bay Area
    I had been facing this problem for years. Here's the final solution that worked every time for me:

    Make sure your DMZ server is the same as your IP address.
  9. ukko88 macrumors newbie

    Sep 16, 2005
    I cant host in Warcraft 3 frozne throne! Help me please!

    Hi , i'm new in this forum. I need help because i cant host warcraft maps in battle net. I have windows xp and i am behind a router Zyxel Prestige 600 or 650 series, i'm not sure.I think i have disable all firewalls but its all invane. In some tutorials i have read that i must open some ports(TCP 6112) in my router but i cant do this. Can somebody tell me a site where is a tutorial step by step for my router or anyone has the same router as mine , who can help me? Please i want to host......Thank who ask me :D :)
  10. jsw Moderator emeritus


    Mar 16, 2004
    Andover, MA
    Sadly, you cannot host unless you can open port 6112 (although you can change that port number in WCIII's settings, so, if you can open another port instead of 6112, or find a port that's open but not being used, you and your friends can use it instead).

    It's easy enough to change the Mac firewall to allow 6112 traffic through; post back if you can't figure that out (on PC at work now and can't post detailed instructions, but, basically, you open System Preferences...->Sharing, go to the Firewall tab, add a new port, label it WCIII or some such, and set it to TCP port 6112). It's similar on XP.

    If you cannot figure out how to change your router's port forwarding settings, you're out of luck. You need to forward that port to your computer. Setting your system up as the DMZ might or might not solve things; you might also need to forward the port explicitly. If you do not have control of your router (some ISPs lock them down), call your ISP. They need to tell you how to forward the port (TCP 6112 or whatever you set it to) to your computer.

    Also, note that you need to make sure your computer has the IP address you've set up - if you use DHCP, that might change, so you'll need to use a manual address to ensure that your computer's IP address stays constant and is what you've set your router to forward 6112 traffic to.
  11. Drakek thread starter macrumors newbie

    Jan 9, 2005
    ummmmm how do i set it to TCP also i have and Airport Wireless connection if that helps
  12. Oere macrumors newbie


    Aug 6, 2006
    San Jose, California
    Dirty computer newb asking for some help and bumping this post. I am so newb I can't find System Preferences and I am sure I have been there before. If anyone can help me with setting this thing up, would be very much obliged.
  13. Mackilroy macrumors 68040


    Jun 29, 2006
    Click on the Apple Menu on the top left of the screen.

    Attached Files:

Share This Page