I can't transfer my photos to my Mac. Ideas?

Discussion in 'iOS 9' started by iRock1, Jan 27, 2016.

  1. iRock1 macrumors 6502a

    iRock1

    Joined:
    Apr 23, 2011
    #1
    Hi,

    I’m trying to transfer all my photos and videos from my iPhone 6 running the latest version of iOS to my Mac under Yosemite. Those files include TIFFs, JPGs and MOVs. However, there seem be some serious issues and I can’t transfer anything.

    I’ve tried with Aperture as I’d normally do, but after opening the Import panel, it loads a few photos (around half of the 225 total files), then it stays on “loading assets” and then the iPhone just disconnects.

    I’ve tried with Image Capture too, but I get similar results — not all the thumbnails are loaded, and even if I try to drag and drop some of the loaded photos, the iPhone disconnects.

    My first guess would be that there is something wrong in those files, but I’ve browsed in my iPhone and all of them look fine!

    I’m seriously desperate with this, as I need to empty my iPhone for a trip in two days!

    Thanks in advance.
     
  2. mikzn macrumors 6502

    mikzn

    Joined:
    Sep 2, 2013
    Location:
    Vancouver
    #2
    Have you tried preview? connect your phone to the mac < open preview and under file < select import from iphone.

    Then you can import the files and afterward you can delete them.
     
  3. ielessar macrumors regular

    Joined:
    Apr 29, 2015
    Location:
    WJ
    #3
    Maybe your cable is faulty? Try a different USB port. Also try importing with Photos. See if you face the same issue.
     
  4. dmnc macrumors 6502

    dmnc

    Joined:
    Sep 26, 2015
    #4
    I would go with a faulty lightning cable. Maybe it was twisted or something, they are actually pretty fragile. Same thing happened to me trying to sync to iTunes.
     
  5. iRock1 thread starter macrumors 6502a

    iRock1

    Joined:
    Apr 23, 2011
    #5
    I tried with Preview and Photos too, nothing worked. Same problem as always: the iPhone disconnects in the middle of the process. (I think there is something messy with the files, even though they look completely fine in my iPhone. They are TIFs saved from Camera+ and always gave my problems).

    Here you have the error messages from Preview and Photos, respectively:

    [​IMG]

    [​IMG]

    I double-checked the cable too. That's definitely not the problem.

    At the end I decided to use a 3rd-party app called iExplorer. That saved my day! Then I viewed my files in OS X and they are fine :).
     
  6. moxxham macrumors 6502

    moxxham

    Joined:
    Mar 8, 2015
    Location:
    Sydney, Australia
    #6
    Just out of curiosity, if you have a newish Mac, have you tried AirDropping them between the devices? :)
     
  7. iRock1 thread starter macrumors 6502a

    iRock1

    Joined:
    Apr 23, 2011
    #7
    Old iMac, no AirDrop. Anyway, as I said a 3rd-party app solved what no Apple app could solve.
     

Share This Page