i disabled iCloud desktop&docs and it wont go away from icloud

Ploki

macrumors 68040
Original poster
Jan 21, 2008
3,980
1,263
how do i force os to stop making these two folders?!
 

sgtaylor5

macrumors regular
Aug 6, 2017
148
69
Cheney, WA, USA
Sad to say, but you can't stop the OS, or rather the iCloud sync service to be exact, from making these folders.

Any app or service you've tried on any Mac or iOS device, even once, that syncs with an iCloud account has a folder or a file(s) in ~/Library/Mobile Documents. That's what you are seeing when you click on "iCloud" in the Finder Sidebar.

For the life of that iCloud account. Apple Support has no way to remove these; I've checked myself.

In Mojave at least, Apple has taken the ability for the Terminal to even see the ~/Library/Mobile Documents folder or its contents, so you'd have to be on an older OS version than Mojave to see those hidden files and folders. Not that you'd want to; they're just infuriating to see them and have them be untouchable. I can see why Apple made them super-hidden. (On Sierra, you could see them; I've never been on High Sierra to have an opinion.)
 

Ploki

macrumors 68040
Original poster
Jan 21, 2008
3,980
1,263
jesus, but i only enabled it to try it out... and because it worked horribly i disabled it, and now i can't get rid of these in my icloud?

that's TERRIBLE.
 

sgtaylor5

macrumors regular
Aug 6, 2017
148
69
Cheney, WA, USA
That’s about it; I wish Apple would have an interstitial page warning the user about this. In detail.

Gets even better; same applies to iCloud accounts themselves. If you setup an iCloud account with a particular email address and delete that account, you can’t use that email address as an alternate email address in any other iCloud account.
 

dsemf

macrumors 6502
Jul 26, 2014
338
71
In Mojave at least, Apple has taken the ability for the Terminal to even see the ~/Library/Mobile Documents folder
System Preferences >> Security & Privacy >> Privacy. Add Terminal to Full Disk Access.

DS
 

cruisin

macrumors 6502a
Apr 1, 2014
956
215
Canada
In Mojave at least, Apple has taken the ability for the Terminal to even see the ~/Library/Mobile Documents folder or its contents
Strange. A simple 'ls' still works for me under Mojave and 'cd' also works. Maybe try 'ls ~/Library/Mobile\ Documents/' ? I don't have Full Disk Access set. Finder shows the folder but clicking it does nothing. Opening the folder on a new tab just opens the same iCloud Drive as on the sidebar.