I downgaded my 3GEN iPod touch 32GB from 3.1.3 to 3.1.2

Discussion in 'iPod touch Hacks' started by JD914, Mar 23, 2010.

  1. JD914 macrumors 6502a

    JD914

    Joined:
    Sep 24, 2007
    Location:
    Dutchess County NY
    #1
    I was previously jailbroken on3.1.2 but had to upgrade when I couldnt get my iPod out of recovery mode a few weeks ago due to something I installed through Cydia.

    I have tried a million different ways to downgrade my iPod touch 32GB to 3.1.2 for jailbreaking. I tried the DFU, shift restore method and kept getting the "apple verifying" message then error message like everyone else.

    This is what I did last night and to my amazement I was able to downgrade back to 3.1.2.

    1- Downloaded the iPod touch 3gen 3.1.2 firmware

    2- Connected my iPod touch to my PC and launched itunes

    3- Here's what I did different: I held the power and home buttons until the usb and iTunes image show up. THIS IS NOT THE DFU MODE METHOD.

    4- hold shift button on PC and press the restore button (on iTunes) search for 3.1.2 firmware (i had it on my desktop)

    iTunes did it's thing and to my amazement I was back on 3.1.2

    I know it's been said a million times that you cant downgrade an ipod touch 3gen 32GB back to 3.1.2 but it worked for me and I'm now jailbroken again. I don't know if it was a fluke or the way I put my iPod in recovery mode instead of DFU mode.

    I hope someone can verify this because I'm still not believing it.
     
  2. br0adband macrumors 6502a

    br0adband

    Joined:
    Aug 29, 2006
    #2
    Barring some minor miracle I don't see how this will work, and like you and thousands of other 3rd gen iPod touch owners, we've all tried this many times over.

    There's a very long, complicated, and somewhat ridiculous thread over at iPodTouchFans about trying to do this, and MuscleNerd, one of the folks that works on the dev team for exploits, Jailbreaks, unlocking, etc (at least I think he does) makes it very clear in many posts in that thread - where nobody seemed to pay much attention - that the standard ways of restoring to 3.1.2 simply do not work anymore.

    Apple has improved things and with the 3.1.3 firmware, they have to digitally sign some of the files that get installed during the restore process. After that - and please understand you can install any firmware you want on the device, really, that's the easy part as MuscleNerd explains it and I understand it - everything is left up to the device. iTunes is only there to feed the files to the device and sign the files when they're transferred over.

    Once they're on the device, it'll reboot and when it does, the new bootrom in 3.1.3 (different from 3.1.2 of course) now checks the signatures on the files on the device as it's booting; if there's a mismatch at any of three stages it won't work, it'll just sit there and you'll be stuck with requiring to do a standard 3.1.3 restore.

    I've tried this stuff myself for the past several days, probably 50 or more various combinations of restore mode, DFU mode, watching file activity, swapping out the dmg files during the process, even went so far as to create a VM and freeze it at each step and alter files in the process, and always for no good reason and with no positive results, ever.

    One good note: geohot, the guy that created blackra1n, just posted a video on YouTube showing an untethered Jailbreak on an iPod touch 3rd gen model, if the video is to be believed.

    http://www.youtube.com/watch?v=__TR86PLiHw

    He followed the "guidelines for a proper jailbreak video" as laid down by the dev team community so, it looks working to me but, I just wish someone would drop the damned thing on us and be done with it.

    But of course, once again it's "oh yeah, I have it, and you don't, so don't ask me about it..." bleh bleh bleh.

    I think I'll just buy something else next time, this stuff isn't worth the hassles anymore. Nobody will ever make the right device and it'll always be a battle getting whatever devices we are "allowed" to purchase to do the things we actually want them to do instead of what the manufacturers think they should do.
     
  3. whyapplewhy macrumors member

    Joined:
    Sep 9, 2009
    #3
    I downgraded my 32gb new ipod 3rd generation to 3.1.2 also. I did about 3 months ago but recently accidentally restored my ipod and forgot how I did it before. I KNOW it can be done as I did it before. I had a completely jailbroken ipod 3rg generation but having troubles figuring out how I did it in the first place. I will try this method and a few other and report back.
     

Share This Page