I have audio issues with my music – not able to detect the problem's source

Discussion in 'iMac' started by iRock1, Mar 11, 2014.

  1. iRock1 macrumors 6502a

    iRock1

    Joined:
    Apr 23, 2011
    #1
    Hi there.

    Since a relatively long time ago (I couldn't say when exactly) I started to notice some issues during my music's playback. It's hard to describe, but it's like my MP3 files were faulty (I hear little and short "cuts"), except that of course they are not.

    I don't know if this is an iTunes related issue, something wrong with the audio drivers, the OS, the speakers or the integrated audio card.

    What I've tried:

    - Playing those files out of iTunes. I used Quicklook and the problem is still there.
    - Freeing memory. It still happens.
    - Restarting iTunes. The same.

    Just in case, I use a late 2009 iMac, with Core i5 processor and 12 GB of RAM. My current OS X version is 10.9.2.

    I hope you can provide me some feedback, because listening to my music this way is driving me nuts.

    Thanks in advance!
     
  2. iRock1 thread starter macrumors 6502a

    iRock1

    Joined:
    Apr 23, 2011
    #2
    Any idea, suggestion, theory? I'm about to throw away my Mac through the window, lol.
     
  3. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #3
    Do you have the same audio issue with YouTube vids?

    How about iTunes Radio? Or, you can play 90 second samples of just about anything in iTunes store - You just want to listen to songs or clips that are not actually on your computer - either streaming, or direct downloads.

    Do you only have problems with the internal speakers? Have you tried headphones?
     

Share This Page