I have MiWi 4.12.6, but supposedly MyWi 4.50.20 with OnDemand is current?

Discussion in 'Jailbreaks and iOS Hacks' started by bella92108, Feb 3, 2011.

  1. bella92108 macrumors 68000

    Joined:
    Mar 1, 2006
    #1
    I'm trying to figure out why MiWi doesn't auto-update to the new MyWi 4.50.20. I bought MiWi and my current version is MiWi 4.12.6. Why am I not getting the update notification for the newest 4.5 with OnDemand I keep reading about?
     
  2. Steven Jobson macrumors regular

    Joined:
    Jan 13, 2011
    #2
    Make sure you have an Internet connection, open Cydia, changes, refresh.
     
  3. bella92108 thread starter macrumors 68000

    Joined:
    Mar 1, 2006
    #3
    Yeah I did. Even when I open cydia, right on the front page it has the MiWi sponsored page and when I click it it shows the 4.12.6 for download... so that's an issue.
     
  4. ngenerator macrumors 68000

    ngenerator

    Joined:
    May 12, 2009
    Location:
    USG Ishimura
    #4
    I've been trying to uninstall MyWi Ondemand for 12 hours just to reinstall and it's not able to be removed. I'd hold off on 4.50.20 for now, but that's just my opinion
     
  5. bella92108 thread starter macrumors 68000

    Joined:
    Mar 1, 2006
    #5
    Where did you get from? Why does mine not show there's a newer version? What repo houses the latest version, maybe I need to re-add the repo.
     
  6. ngenerator macrumors 68000

    ngenerator

    Joined:
    May 12, 2009
    Location:
    USG Ishimura
    #6
    Sorry, idk what the repo is, but I've had the same MyWi since it was updated to 4.0. I have no idea why it's not showing as an available update for you, that's weird
     
  7. bella92108 thread starter macrumors 68000

    Joined:
    Mar 1, 2006
    #7
    Yeah, not sure why either. MiWi's webpage doesn't even show a version 4.5 (or any version for that matter), so not sure what's going on.

    Does anyone who have 4.5 legitimately tell me where they got it? When I google it it's all the hack sites, so I'm wondering if there's no such thing as an official 4.5.x release.
     
  8. ngenerator macrumors 68000

    ngenerator

    Joined:
    May 12, 2009
    Location:
    USG Ishimura
    #8
    I just looked, it's in ModMyi :) I'm going to try removing and reinstalling that repo, maybe that'll help you too
     
  9. bella92108 thread starter macrumors 68000

    Joined:
    Mar 1, 2006
    #9
    I tried to delete and readd the repo, it's http://apt.modmyi.com right? It's saying it's not a valid Cydia Repo. :-(
     
  10. ngenerator macrumors 68000

    ngenerator

    Joined:
    May 12, 2009
    Location:
    USG Ishimura
    #10
    Just use search, it shows up fine for me
     
  11. bella92108 thread starter macrumors 68000

    Joined:
    Mar 1, 2006
    #11
    Search? You realize when you "Search" it ONLY searches the repos you have installed, right? When I search MyWi it doesn't show up because I clearly don't have the repo installed...

    Also tried http://modmyi.com/cydia/ and it threw all sorts of zip errors and failed to fetch at me, and then didn't add.
     
  12. ngenerator macrumors 68000

    ngenerator

    Joined:
    May 12, 2009
    Location:
    USG Ishimura
    #12
    Umm, I meant search for modmyi.com, it should allow you to remove from there and reinstall
     
  13. bella92108 thread starter macrumors 68000

    Joined:
    Mar 1, 2006
    #13
    I googled the hell out of it and can't find it. Lots of people reporting problems with the overall stability of their repo, but none addressing my issue. Have you been able to add it today?
     
  14. ngenerator macrumors 68000

    ngenerator

    Joined:
    May 12, 2009
    Location:
    USG Ishimura
    #14
    Search for "modmyi" in Cydia, down by the "Manage" and "Changes" buttons, the magnifying glass
     
  15. bella92108 thread starter macrumors 68000

    Joined:
    Mar 1, 2006
    #15
    OMG!

    You need to read this 2, 3, 4 or however many times until you understand it:

    The "Search" in Cydia is not an internet search engine. A repo (repository) is a site that houses certain SPECIFIC applications. When you first install Cydia, there are 4-5 repos installed, such as BigBoss. When you click SEARCH, it searches ONLY the packages in the installed Repos. ModMyI is located in the ModMyI repo, so if one doesn't have ModMyI repo installed, a search will return NO results.

    The issue I'm having is adding the ModMyI repo. You can tell me to search all I want, but much like someone has to add the ultrasnow repo before they can download ultrasnow, one has to install the ModMyI BEFORE the update\package can be installed from that repo. Please do not reply to say it's just a matter of searching, as you need to understand how the process actually works.
     
  16. ngenerator macrumors 68000

    ngenerator

    Joined:
    May 12, 2009
    Location:
    USG Ishimura
    #16
    Well it just goes to show no matter how good your intentions are to try and help, some people will still have a bug up their ass. Enjoy 4.12.6!:)
     
  17. bella92108 thread starter macrumors 68000

    Joined:
    Mar 1, 2006
    #17
    It's always better to keep quiet if you don't know what you're talking about. When you volunteer information that's wrong, it only serves to make someone distrust anything you say.
     
  18. bneyman, Feb 3, 2011
    Last edited: Feb 3, 2011

    bneyman macrumors newbie

    Joined:
    Feb 3, 2011
    #18
    I successfully updated MyWi to 4.50, but it was a struggle. At first I purchased the On Demand upgrade on Cydia and installed. That did not update the app. So I uninstalled first MyWi On Demand, then uninstalled (Removed) MyWi 4.0, figuring that, since it wasn't showing up as an available update that there was some kind of problem with Cydia's update function.

    Then I installed MyWi, again using Cydia, and validated my license. With this fresh install the 4.50 version was delivered. It took a couple of restarts before MyWi ran without asking for a reboot. After that I reinstalled my license for MyWi On Demand, again going through a couple of restarts before it worked.

    This all took place on my jailbroken iPhone 3GS running 4.0.1. On my jailbroken iPad WiFi running 4.2.1 I installed MyWi from Cydia, which recognized my license and installed both MyWi 4.50 and On Demand in the same pass. I had to restart twice for each license to work, but everything was OK after that.
     
  19. kre62 macrumors 68000

    Joined:
    Jul 12, 2010
    #19
    When he was telling you to search, he was saying to use your eyes and look for the repo. Modmyi is installed as a repo by default on all jb phones.

    Good thing you "educated" him with that tirade about repos though...
     
  20. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #20
    That's the prob, dont try to help or have a conversation with the OP.
    You will get nothing but rude and stuck up comments. Better save your help and efford towards someone who appreciates it instead of getting an attitude in return;)
    Modmyi is installed by default with Cydia BTW.
     
  21. threezero macrumors 6502

    Joined:
    Aug 22, 2008
    #21
    you guys really need to read.
    the problem that OP is CURRENTLY having is that he

    deleted the modmyi (which yes comes default with cydia)
    and cannot add it back


    and he is asking whether anybody else have this problem of not being able to add back modmyi repo after deleting it

    i hope i got this right and sorry i can't help you. i doubt many ppl have had deleted the modmyi repo and try to add it back on thus the confusion and the lack of help.
     
  22. Steven Jobson macrumors regular

    Joined:
    Jan 13, 2011
    #22
    You can add it back manually in the cydia plist by SSHing into it.
     
  23. bella92108 thread starter macrumors 68000

    Joined:
    Mar 1, 2006
    #23
    Yeah, the REASON (thanks for asking everyone) that it wasn't there was because one of the repos I'd added was corrupt, so I had to delete all and start from scratch, that's why I was asking how to reinstall it.

    Since I went from tethered to greenpoison untethered yesterday, the issue obviously went away, since many have pointed out it comes with Cydia by default so it's back :)

    Thanks!
     
  24. braddick macrumors 68040

    braddick

    Joined:
    Jun 28, 2009
    Location:
    Encinitas, CA
    #24
    Purchasing the upgrade of "OnDemand" automatically updated MyWi too. Sadly, without a jailbroken iPad my purchase was somewhat in vain.
     

Share This Page