I just want to move my Photos library!

Discussion in 'Mac Apps and Mac App Store' started by Michael CM1, Jul 22, 2015.

  1. Michael CM1 macrumors 603

    Joined:
    Feb 4, 2008
    #1
    I swear this process couldn't be harder. I've tried about eight times to move my MacBook Air's Photos library from it to a WD NAS system (a 4TB My Cloud device). I've got a share created called Photos and I'm trying to drag and drop it over there.

    The best I'm getting is to 11.20GB out of about 15GB before I get some error 36. I'm in the middle of like my third attempted fix for that issue -- found an app that deletes DS Store files -- but I'm still wary.

    I've still got to figure out how to get 200GB of photos out of my Time Machine backup of my iMac that I probably killed last night thanks to the DisplayPort cable inside. I mean those are my damn pictures and videos. Since I'm likely just going to be a MacBook Air person now unless I get lucky and figure out how to fix my iMac, I've gotta get this Photos Library on an external drive thing figured out.

    Anybody else have these types of issues? It's a bitch moving huge files like this across a wireless network connection. It's bad enough when it's over USB.

    Also if anybody knows of a good set of reading on managing all sorts of media externally using a MacBook Air, I'd love to know about it. All of my TV comes in on my Apple TV boxes, and I have a bunch of movies stored on hard disks. It's fine watching when my MBA is awake and open, but that doesn't really work when it's not. I'm likely to invest in a new display to make clamshell mode a possibility, but I remember that not being a perfect solution about five years ago with a MacBook Air.
     
  2. markfc macrumors 6502a

    markfc

    Joined:
    Sep 18, 2006
    Location:
    Prestatyn, Wales, UK
    #2
    Not sure if its the same as iPhoto but I'm fairly sure you can't run it over a NAS box.

    The NAS won't be formatted to Apple HFS+ Right?
     
  3. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #3
    I ran my Aperture Library on a NAS, for NAS units, it doesn't need to be HFS+ i.e., my Qnap NAS uses ext4 as a format it Aperture handled just fine. As long as the NAS unit uses AFP, I think you can store the library on the NAS.
     
  4. Michael CM1 thread starter macrumors 603

    Joined:
    Feb 4, 2008
    #4
    This one uses EXT4 on the internal hard disks. It supports the following for disks you attach via the USB ports in the back:

    • FAT/FAT32
    • NTFS (read and write capability)
    • HFS+J (case sensitive)
    • Linux EXT2, EXT3, EXT4

    I had never heard of those Linux ones before. Anyway, I decided to create a new one since the one I had on here was continually giving me problems at 11.20GB when trying to make a copy. Created a new library on a /photos share on the NAS drive. So far so good, except it's obviously damn slower.

    My next problem is plucking 200GB of photos out of the Time Machine backup for my iMac that I messed up last night. I know it's possible, but 200GB of photos takes a long time to do anything. I also have zero clue how I'm supposed to get those photos from just the library file. Ugh, to the Google machine I will have to go.
     
  5. ricosuave macrumors 6502

    ricosuave

    Joined:
    Mar 27, 2007
    Location:
    In front of my mac
    #5
    Instead of dragging the library, rename it. Then create a new one on the external and assign it as system library and let it download all the photos.
     
  6. Michael CM1 thread starter macrumors 603

    Joined:
    Feb 4, 2008
    #6
    All of this is now moot after semi-fixing my iMac by using an external monitor. I now have a 2TB internal drive again and thus no issues with space. Thank goodness because it was not easy to figure out and I'd rather use the extra 200GB of space for videos instead of photos.
     
  7. rhett7660 macrumors G4

    rhett7660

    Joined:
    Jan 9, 2008
    Location:
    Sunny, Southern California
    #7
    Just make sure you have a back-up of your videos and photos.
     
  8. Michael CM1 thread starter macrumors 603

    Joined:
    Feb 4, 2008
    #8
    I do. I've got a net 4TB NAS drive (two 4TB drives using RAID mirroring) storing my Time Machine backup. So I've got a backup for my backup. I'll probably move the old Time Machine drive to the external USB port on that NAS since double backup isn't really necessary and I may need the room. But I definitely know the lessons of not backing up.
     
  9. markfc macrumors 6502a

    markfc

    Joined:
    Sep 18, 2006
    Location:
    Prestatyn, Wales, UK
    #9
    Don't consider Raid as a double backup.

    Raid is for availability, not for backup. You should be backing up the Raid volumes too.
     
  10. aarond12 macrumors 65816

    aarond12

    Joined:
    May 20, 2002
    Location:
    Dallas, TX USA
    #10
    There appears to be a limitation that the Photos Library hits with AFP that causes this issue. I cannot copy a Photos Library over AFP from one Mac to another (same error as above -- "some information cannot be read or written"), but I can write it to a HFS+ formatted thumb drive and read it on another computer from the same thumb drive.

    What's also interesting is that I can compress (ZIP) the Photos Library and all the files can be read. This points the finger at AFP.

    Looking at the contents of the Photos Library, it doesn't appear to be a path length issue, so I'm kinda stumped. Apple's developer guide for AFP says it won't accept paths greater than 255 characters. The file structure doesn't appear to go that deeply, but there are some odd characters -- folders that start with "%" for example.
     
  11. jasnw macrumors 6502

    Joined:
    Nov 15, 2013
    Location:
    Seattle Area (NOT! Microsoft)
    #11
    Two things:

    1. Unless you have a wired network, keep your photos library (iPhoto or Photos) local (internal HD or external USB HD). If you have to go wireless and want your library on a different machine, expect sluggish response.

    2. I keep my multiple iPhoto libraries on a Mac Mini server on external USB drives. I use rsync to keep two working libraries (mine and my wife's) sync'd to the server copies (which are backed up to another external HD). The Unix rsync tool is used by many of the third-party backup tools like CCC. It can be tricky using rsync on the Mac filesystem, but there are a number of articles on how to do this.

    (Note - I'm doing all this on Mavericks. I'm waiting for El Capitan 10.11.4 before I upgrade the OS.)
     

Share This Page