I know Its Been Discussed But 10.5.4 Killed My Imac Wifi Signal..

Discussion in 'iMac' started by Peruvian, Jul 8, 2008.

  1. Peruvian macrumors regular


    Jun 10, 2006
    I have an ALU 3.06 Imac, which was working perfectly until I upgraded to 10.5.4... now I get numerous wifi dropouts.. Its not the router because I have a core duo macbook(the first release) which is also updated to 10.5.4 and is running with no problems at all....

    Is there any patch or anything I can put into terminal to fix this... It really is a pain in the a**

    Thanks P.....
  2. edesignuk Moderator emeritus


    Mar 25, 2002
    London, England
    Random possible solution...

    Try switching the channel the Wi-Fi operates over, try 11. Our iMac G5 after an update decided it didn't want to work anymore, after doing some Googling I found the recommendation to try another channel, specifically 11. Worth a shot.
  3. Cynicalone macrumors 68040


    Jul 9, 2008
    Okie land
    There is a new Firmware update out for Time Capsule and Airport Extreme, don't know if that'll help?.?
  4. Lexoticstylez02 macrumors 6502a


    Oct 11, 2007
    Orlando, Florida
    I've noticed this as well.. I constantly have to turn Airport off and on and reconnect to my network after 10.5.4
  5. samuir macrumors newbie

    May 17, 2008
    any solution?

    hi, im also facing the same problem like you so how do u solve it? for me i just config my router to just "G" network and it work but the main thing is, why i have to down my network setting since the laptop is designed for "N" Network so pls share ur solution. thanks alot
  6. Meave macrumors newbie

    Aug 7, 2008
    Try changing the wep key to a longer one, I forgot whats it called but that helped me.
  7. daneoni macrumors G4


    Mar 24, 2006
    If these dont work try switching off wi-fi, trashing your keygen database (especially the airport related keys), going to HD>Library>Preferences>System Configuration and trashing the following files:

    Network Identification.plist
    Airport preferences.plist
    Network interfaces.plist

    restart your mac and turn on airport and find your network, select it and just follow instructions from there

Share This Page