I moved all my files to an SSD. How can I safely wipe my old HDD except for some specific files?

Discussion in 'OS X Yosemite (10.10)' started by iRock1, Aug 17, 2015.

  1. iRock1 macrumors 6502a

    iRock1

    Joined:
    Apr 23, 2011
    #1
    Hi,

    I've just installed an SSD on my iMac, installed Yosemite on it and transferred there all my data (apps, documents, settings, etc.) from my old hard drive (which used to be a Mavericks startup partition and now is working as a secondary unit for larger files)

    What I need to do, first, is to relocate my Aperture Library from Old Disk\Users\User\Pictures, to a new folder in Old Disk\Pictures.

    What I did was to try opening that file from Photos in Yosemite (which is running in my SSD partition). I confirmed that the app is crap and has nothing to do with Aperture, then I decided to manually move the Aperture file to the main root in my hard drive. What happens next is that if try to open that file with Aperture under Yosemite, it runs the following error:

    [​IMG]

    However, if I put the file back in the Old Disk\Users\User\Pictures root, it runs with no problem at all.

    So the first question is, what's going on, and how can I relocate my Aperture Library?

    The second question is, how can I delete the rest of folders in my old hard drive (OS, files, etc.)? I tried just selecting everything but my movies and pictures and sending all to the trash, but I discovered that OS X insist in keeping a folder in this path: System\Library\Caches\com.apple.kext.caches\Startup.

    For me it could be as easy as taking the Aperture Library and my movies, back them up to an external drive and format the old hard disk. However, as I've seen how picky Aperture can get with roots and formats and stuff, I don't want to touch anything yet as I'm risking a total loss of my photos.

    Thanks for your help.
     
  2. iRock1 thread starter macrumors 6502a

    iRock1

    Joined:
    Apr 23, 2011
    #2
    Ok, a little update on the Aperture library issue.

    I've discovered, odd enough, that if I try opening the library file from the original root, I get the error message that I posted earlier. However, if I just open up Aperture from the Apps folder, it will open that library as the default one with no problem at all, even when they are exactly the same file (!!!???).

    Anyway. Once I was able to see the content of my photo library in Yosemite, I selected all my projects, then went to File > Export > Project as New Library... and selected an external drive as the target destination. Once the process was complete, I opened up the new library file that was just created, and confirmed that it was ok.

    Now I asume that my library file is fine on an external disk. I have to note though that, while all my photos seem to be completely ok, the library file is different in size to the original one, which is located in the hard disk that is currently installed as a secondary drive on my iMac. It's not a huge difference, but I suppose they should be exactly the same and they aren't (265,34 GB v 259,68 GB and even 260,63, which is a second backup that I did following exactly the same process described before but this time on another external drive).

    What I'm tempted to do now is just formatting the hard disk currently installed on my iMac, and then moving my library from the external drive back to the hard disk. That would solve the problem of wiping up my secondary drive, though I'm still afraid of screwing up my photos.

    Any suggestion?
     
  3. Antonio Blanco macrumors member

    Antonio Blanco

    Joined:
    Sep 25, 2014
    Location:
    Puebla - México
    #3
    i'd recommend you to download disk doctor from the mac app store....
     
  4. iRock1 thread starter macrumors 6502a

    iRock1

    Joined:
    Apr 23, 2011
    #4
    Never mind, I just used Disk Utility to format the old HDD.

    On the Aperture issue, most of my problems were solved by keeping pressed ⌘⌥ while opening the app. That displays a "first aid" menu with three different procedures that are helpful for this kind of cases.
     

Share This Page