I need help!!! DVD Playback problem on G5!!

Discussion in 'Mac Apps and Mac App Store' started by msharp, Jul 17, 2004.

  1. msharp macrumors regular


    Jul 10, 2004
    anyone could help me with the dvd playback problem on G5(i don't know if this problem only shows up on G5s)??

    i inserted a dvd disc, and the dvd player shows up with no sound at all!!
    and after that i checked the Sound preference in the System Preferences panel, the output setting was changed to Built-in Audio:Digital Out instead of the correct setting: Built-in Audio:Line Out.

    And, the setting was grey that i can't even change it back to normal... And the whole system was muted... :(

    The only way to resolve this problem is restarting the machine. :(

    i've tried several times but the problem stills, and i've searched all over the web(via google) with no result.

    Thanks everyone in advance....!!
  2. Nermal Moderator


    Staff Member

    Dec 7, 2002
    New Zealand
    Does it happen with every DVD, or just one? If it only affects one, try going to that DVD's audio setup menu, and make sure it's not set to DTS (which Apple's player won't decode).

    You could also try using VLC for playback.

    NB: I don't own a G5.
  3. stoid macrumors 601


    Feb 17, 2002
    So long, and thanks for all the fish!
    I'll guarantee you that it is a G5 only problem. It is the only Apple computer with the Tos-Link Fiber Optic Digital Audio in/out ports. How old is the computer? Call Apple, your sound card may be bad.
  4. live4ever macrumors 6502a

    Aug 13, 2003
    I remember one time playing a dvd with no audio being apparent, it turned out that the volume on DVD Player.app controller was all the way down to nothing.

    Try playing the DVD in VLC or a vob in QT to see if you get sound there, then try deleting DVD Players prefs.
  5. msharp thread starter macrumors regular


    Jul 10, 2004
    i tried vlc but it doesn't work...

    yes, i trid VLC 0.72, that doesn't work as well :(
    when play this dvd(i haven't tried other dvd yet) it prompt me as followed:
    coreaudio: failed to set buffer size: [nope]
    thanks everyone... :)
  6. msharp thread starter macrumors regular


    Jul 10, 2004
    my G5 is only less than a month old...so i think it can't be bad... although this is the first time i bought products from apple, I think i can trust in apple, also trust in their products.

Share This Page