I need urgent help. External drive with only copy of iphoto library corrupted!

Discussion in 'OS X Mountain Lion (10.8)' started by ace.neerav, Oct 11, 2013.

  1. ace.neerav macrumors newbie

    Joined:
    Jun 14, 2009
    #1
    please have patients with me... i know i have been stupid... Here is the scene...

    i have a seagate 1 tb hdd which is designated as my tm backup drive. i did the huge mistake of "moving" (yes moving!) my old iphoto library with 10 years of photograph on this drive along side the backup folder.

    now for some reason the drive wont mount since 2 days. disk utility indicates its corrupted! repair gets stuck for ever in "updating boot partitions in volume as required".

    I DONT CARE ABOUT THE TM BACKUP, but I need my 10 years of photograph back! i just thought that the one on the tm partition was an "extra" back up only to realise that it was the only one!!!!!

    i can't explain the panic. i know its just photographs but they mean a lot to me.

    i tried some free data recovery softwares and they do indicate the library is there but they wont let me recover unless i bought the paid version.

    i want to spend my money only on the best one for the mac, time tested sort of.


    also, on that note, if someone can tell me if its a good idea to buy a 4tb lacie cloud box nas storage for backup and also to keep data [movies etc...] or should i get a RAID one?
     
  2. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #2
    I can't help you on which data recovery program is best, but I do have a piece of advice: Do *not* put your data and backup on the same drive or in the same external enclosure. If the enclosure has issues you lose your data and your backup.
     
  3. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
    #3
    I'll try to help.

    First, if the directory on the seagate drive has become corrupted, it may still be possible to get the data back.

    HOWEVER -

    It's going to cost you time, and it's going to cost you money. If you want the data back, you'll have to spend the money. There is no way around this.

    If you have DiskWarrior, it might be worth trying on the problem drive first. DW is designed to ONLY repair and rebuild directories. It may help, or it may not.

    If DiskWarrior DOESN'T work, then you're going to have to move beyond "directory repair" to "data recovery" (two different things).

    You're going to need some hardware:
    1. A new "bare" drive from the vendor of your choice, at least 1tb in size
    2. A USB3/SATA docking station. To see what these are, go to amazon, and enter "usb sata dock" in the text search box. I would recommend something from plugable.com (no financial interest other than being a paying and satisfied customer). This will cost you less than $25.

    You're going to need some software:
    - Data recovery software, such as "DataRescue3", which has one of the best track records for getting lost data back.

    DR3 _might_ be able to "get to" the data "as is", even if the drive is not currently "mountable" (i.e., corrupted directory that prevents it from being mounted on the desktop).

    But if DR3 can't "see" the drive, you can STILL get at the data. I had a corrupted partition with mp3 files on it, that even DR couldn't mount. What to do next?

    My solution (and it's not for the feint-of-heart):
    I _re-initialized_ the entire drive into a single partition. But -- I _did not_ "zero out" the data. All I did was replace the corrupted directory with a "clean" one, leaving the data intact on the drive.

    Now, the drive mounts up and "looks empty". That's because the directory is brand-new. But the old data remains intact on the sectors of the drive, until it's over-written with new data.

    Next step:
    I ran DataRescue on the seemingly-empty drive. Because DR is designed to ignore the directory and go "right to the platters", it FOUND the "old data", scavenged the files, reconstructed them, and then saved them to my "scratch drive" (this is why you need a second drive to serve as your "recovery drive").

    I got the files back.

    BUT -- something you must be aware of with data recovery software -- you will almost certainly lose all your pre-existing file names and folder hierarchies. This is because names and folders are "constructs of the old directory", which was deleted and replaced with a NEW directory (with nothing in it). That's the "price you pay" for getting the actual data files back.

    Aside: assuming the photos have metadata, you _might_ be able to dump the entire set of recovered files into iPhoto or another photo-cataloguing app that can sort by metadata, and get the filenames back (this worked for my by creating a new iTunes library with my "un-named" files -- iTunes read the tags, and used that info to name the files).

    Again, if this looks involved, it is.
    This is the price you pay for not being careful by maintaining at least TWO COPIES of precious data files.
    But if you want the stuff back, you're going to have to spend the time and money.

    In the future, I suggest that you DO NOT use Time Machine.
    Instead, use CarbonCopyCloner -- much better.
     
  4. benwiggy macrumors 68020

    Joined:
    Jun 15, 2012
    #4
    There's nothing here to suggest that TM was at fault: the drive stopped working. Using CCC would have not changed anything.
    Otherwise, you've pretty much covered everything meticulously! :p
     

Share This Page