I set my whole Macintosh HD to "everyone can read and write" - huge mistake???

Discussion in 'macOS' started by annamac, Nov 13, 2008.

  1. annamac macrumors member

    Joined:
    Jun 13, 2008
    #1
    Hi, i just bought a new macbook pro 2.53Ghz (and LOVE it).
    when i transferred my users via ethernet from my old mac to the new mac, eerything worked, except that the finder kept asking me all the tim to identify myself (for every copy, delete etc. action).
    that was really annoying, so i clicked on the Macintosh HD symbol, and changed (including all subfolders) the user rights to "everyone read and write"...
    and now i am afraid that that might have consequences i cannot foresee..
    what do you think????
     
  2. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #2
    You shouldn't do that from a security stand point. Run disk utility and repair permissions to set things how they should be.
     
  3. annamac thread starter macrumors member

    Joined:
    Jun 13, 2008
    #3
    thank you!
    i tried to repair the rights with the disk utility, but it says:

    error: the process reports an error while closing (or quitting) or stopping or sth

    is that because i try to fix the HD i am working from?
    or what does it mean?
     
  4. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #4
    If your doing repair disk permissions vs repair disk it should be able to do it from a disk your working on. You could try doing it from the install disk though.
     
  5. mason.kramer macrumors 6502

    mason.kramer

    Joined:
    Apr 16, 2007
    Location:
    Watertown, MA
    #5
    Yeah, this is basically the antithesis of security. You should fix this is you _at_ _all_ care about security.

    It sounds like the problem is that the files were owned by someone who was not the user. For instance, if the usernames changed during the system transfer. I can help you repair your permissions, but I need to know what to change.

    Open Terminal. It is in Applications/Utilities. Alternately, use spotlight search to find it. cmd-spacebar, type terminal and it should be the first hit.

    Now, open terminal, and use
    Code:
    ls -leo /Users/
    ls -leo /Users/user1
    ls -leo /Users/user2
    
    where user1 etc are the names of the folders in the /Users/ directory.

    and if you want, post your output here.

    This command gives a detailed description of the permissions that each user's Home directory has. It also lists the owner of each folder.

    After this I can give you some commands to repair the old permissions system and then change the owner to the correct owner, if you want.
     

Share This Page