iPhone X I think I’m going crazy

Discussion in 'iPhone' started by dooku77, Oct 5, 2018.

  1. dooku77 macrumors member

    dooku77

    Joined:
    Nov 24, 2014
    #1
    Can anyone with T-Mobile confirm that they have terrible signal in places you use to have good signal with whatever phone you use to have? I’m using the Xs Max and I lose signal going into restaurants now and even going into the mall. I’ve soft, hard reset and reset network settings. I’ve seen all the videos and reports, but I didn’t think it was this bad. I had service everywhere when I had my X.
     
  2. Ml989 macrumors newbie

    Joined:
    Nov 20, 2017
    #4
  3. dooku77 thread starter macrumors member

    dooku77

    Joined:
    Nov 24, 2014
    #5
    I would if I wasn’t 1 day past the return period. I’m stuck with this thing now. Hoping a software fix will do the trick like the old days when we use to flash new radios on Blackberries.
     
  4. Ml989 macrumors newbie

    Joined:
    Nov 20, 2017
    #6
    Yeah I returned mine today which was the 13th day of the return period...

    I’ll be honest, the Xs was the worst iPhone I’ve ever owned. I NEVERhad any problems with any iPhone I’ve had, and since the X and Xs they’ve been disappointing me....

    So I said screw it, and returned the Xs today for an iPhone 8, and got almost half my money back and the phone does the same thing!
     
  5. dooku77 thread starter macrumors member

    dooku77

    Joined:
    Nov 24, 2014
    #7
    I wish I would’ve done the same. These last 14 days I just couldn’t believe it was happening to my phone.
     

Share This Page

6 October 5, 2018