I thought battery threads were lame until…

Discussion in 'iOS 8' started by ToddH, Jun 30, 2015.

  1. ToddH macrumors 6502a

    ToddH

    Joined:
    Jul 5, 2010
    Location:
    Central Tx
    #1
    Since I upgraded my iPhone 6 Plus to version 8.4, my battery has dropped 30% in one hour. I've seen many posts on these threads regarding people complaining about their battery dropping, and I guess I always thought it was ridiculous or not true. However for the first time, I'm seeing it for myself. Does anybody else have this issue? My photo gallery is all messed up as well and I will have to fix it when I get home.
     
  2. gsmornot macrumors 68030

    gsmornot

    Joined:
    Sep 29, 2014
    #2
    I just plugged my iPhone in mid-day for the first time in a long time. I'm at 40% but I assumed it was/is something to do with the amount I'm playing with music and the update and all that. I would not panic until you get to tomorrow and see how it runs.
     
  3. simon lefisch macrumors 6502a

    simon lefisch

    Joined:
    Sep 29, 2014
    #3
    Wait a day or 2 for the OS to settle. Things have been changed and need to propagate. If you're still having the same probs after a couple days, then do a restore.
     
  4. ToddH thread starter macrumors 6502a

    ToddH

    Joined:
    Jul 5, 2010
    Location:
    Central Tx
    #4
    Well I don't think that I will panic about it. It just may be coincidence and I was using my maps for navigation while I was driving for a good hour and during that time it dropped 30% I just don't recall that being normal on this phone. Anyway I'm going to let the battery drain down nearly all the way since I have not done that in a while and hopefully it will reset the battery clock and percentage amount. Anyway thank you for the reply, have a good day.
     
  5. coldsweat macrumors 6502

    coldsweat

    Joined:
    Aug 18, 2009
    Location:
    Grimsby, UK
    #5
    My battery life is shot since the 8.4 update, I can close all apps & watch the battery percentage drain by 1% every 20 seconds (yes I timed it & yes I probably need to get out more!)
     
  6. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #6
    Sounds like some process is stuck. Have you tried restarting? Resetting network settings if not all settings? Down to restoring if none of that works?
     
  7. mpfuchs macrumors regular

    mpfuchs

    Joined:
    Sep 19, 2014
    Location:
    VA
    #7
    My battery life was terrible yesterday.
    Hmm... That might have had something to do with me streaming beats 1 all day.
     
  8. mpavilion macrumors 6502a

    Joined:
    Aug 4, 2014
    Location:
    SFV, CA, USA
    #8
    I'm having the same issue with my navigation app (Waze). Just posted this in a different thread, then saw this one...
     
  9. PilotC150 macrumors member

    Joined:
    Apr 24, 2015
    #9
    Same issue here. Yesterday I thought it was because I was downloading a bunch of songs from Apple Music. Today I've just been playing music the same way I do everyday and I'm down to 66% and it's only mid-afternoon. Usually I'm still in the 80's at this point.
     
  10. jev425 macrumors 6502

    jev425

    Joined:
    Sep 12, 2014
    Location:
    Seattle, Washington
    #10
    I have noticed with any update that I make restoring to "brand new phone" and giving it a day or two fixes any battery issues I have had in the past when I "overlap" the update over the old instead of a fresh install
     
  11. postpc macrumors regular

    postpc

    Joined:
    Sep 3, 2013
    Location:
    Germany

Share This Page