I upgraded my unlocked 3gs to 5.0.1 and I don't think I should have.

darthsoth

macrumors newbie
Original poster
Jan 25, 2012
13
0
Medicine Hat, Alberta, Canada
Hello all. I have a 3gs that I bought used and already unlocked so that I could use any carrier on it. It was running 4.5.3 on it and I just upgraded to 5.0.1. Pretty sure I shouldn't have do that. Now I can jailbreak it with RedSn0w but I can't get my carrier to work. What are my options here? I don't suppose I can go back to os 4 can I?

I have a 3gs, os 5.0.1, modem firmware 05.16.05, the serial #'s 3,4,5 #'s are 931.

I have been reading a bunch of different walkthroughs but seem to be getting some conflicting and confusing info about what I can do.

I have RedSn0w 0.9.10b4 and have just restored my factory settings through itunes so that I can potentially go to the ipad baseband 6.15 but when I select that option I get a message saying that it will not work on build dates 11-35 or later. By later do they mean newer? or older? I clearly have an older built 3gs but the wording later to me means older.

Basically at this point I am looking for some help and advise as to what I should do. If I can get my phone unlocked so that I can use my current carrier without going the ipad route then I'm all for that. But if the ipad baseband is the only way then I can do that. please help.

Edit: forgot to mention that I am using an imac os x computer.
 
Last edited:

darthsoth

macrumors newbie
Original poster
Jan 25, 2012
13
0
Medicine Hat, Alberta, Canada
By later, they mean newer. Those 3GS made in 2011, week 35 or above. Yours was made in 2009.
Thank you. That was what I thought but I really wanted to make sure I wasn't digging myself a deeper hole if you know what I mean.

So is changing to the ipad baseband the only option for me? It is irreversible so I'd like to know if I could do something else before going that route.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.