I upgraded to iOS 5 and now my Google Maps app is in CHINESE!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by BobJenkins, Oct 13, 2011.

  1. BobJenkins macrumors newbie

    Joined:
    Oct 13, 2011
    #1
    I bought an unlocked iPhone 4 in Hong Kong last year and my Google Maps app was normal (in English.) I recently moved to Shanghai and after upgrading to iOS 5 earlier today my Google Maps app is all in Chinese! This includes street names, buildings, parks...everything! Even when I look at places outside of China (like in America for example) everything is still in Chinese. I can't read Chinese characters, so does anyone know what I can do to get my Google Maps app back to normal?

    By the way, I know that the iPhones which are bought in China come like this, but I didn't buy my iPhone in China, I got it in Hong Kong where the Google Maps app is normal (and has been normal for the last few months.) I know that this is obviously a software issue because it changed with this new software update, so does anyone have any suggestions?
     
  2. emaildothales macrumors newbie

    Joined:
    Oct 13, 2011
    #2
    Same problem

    I have the same problem.

    In my case I have a hongkong iphone 3gs. And my life in Shanghai with a map only in Chinese is going to be very very hard.

    Seems like this was iphone strategy to make hongkong iphone like this know. They don't want westerns going to hongkong and getting cheaper iphones.

    If I can't solve this problem, I will have to get the IOS 4 back or I will buy a droid phone, I think

    thanks

    Thales
     
  3. thewitt macrumors 68020

    thewitt

    Joined:
    Sep 13, 2011
    #3
    Where does

    Settings - General - International - Region Format

    Think you are...
     
  4. emaildothales macrumors newbie

    Joined:
    Oct 13, 2011
    #4
    Thanks for the suggestion, but this does't work. everything in the iphone still in english, beside the google maps

    do I have to jailbrake it?
     
  5. BobJenkins thread starter macrumors newbie

    Joined:
    Oct 13, 2011
    #5
    The regional format is the United States. Any other suggestions?
     
  6. lpgn macrumors newbie

    Joined:
    Oct 13, 2011
    #6
    this afects a Brazilian phone upgrade in shanghai too!

    I have the same problem but the difference is my phone like me is brazilian and my IPAD is bought in USA so this is ridiculous. My location settings is the same as before Brazil, the only thing that could have trigged this is where I am connected to the internet, I am in Shanghai now. I will try to upgrade another IPAD using my VPN all the time.
     
  7. lpgn macrumors newbie

    Joined:
    Oct 13, 2011
    #7
    It worked!!!

    It worked Maps are in english! Now I will restore the other devices using my VPN to see what is going to happen.
     
  8. Estratos macrumors newbie

    Joined:
    Oct 11, 2011
    #8
    I have the same problem (iPhone bought in Poland, factory unlocked). iOS 4.3.5 - maps in English/pinyin and after the upgrade Chinese only. :(

    I have tried restoring using a VPN on my computer, but with no result, as my iPhone connects to a Chinese wifi network.

    The only thing that worked was to change the SIM card to a Polish one, and connect to the Internet. That seemed to help, the maps were back to normal, but right after inserting a Chinese SIM card, everything went back to Chinese. So frustrating!!
     
  9. BobJenkins thread starter macrumors newbie

    Joined:
    Oct 13, 2011
    #9
    I just restored my iPhone with my computer's VPN connected (which says I am in San Francisco) and my Google Maps app is still in Chinese. I did a full on factory settings restore, not a retore from backup.

    What did you do exactly?
     
  10. emaildothales macrumors newbie

    Joined:
    Oct 13, 2011
    #10
    So what I could understand is that just with your Ipad the VPN solution had worked, right?

    But not with your iphone yet, is that correct?

    I also restored my iphone using VPN a, I also removed the chinese SIM during the process.

    I will repeat the process using VPN + my brazilian SIMCard to see what happens.
     
  11. RobShanghai macrumors newbie

    Joined:
    Oct 14, 2011
    #11
    App that might fix

    Same problem, my IPhone is Singapore version and I used my VPN in Shanghai to connect to ITunes for the upgrade to IOS 5 but still maps in Chinese. The following day my screen also went blank, coincidence ? Don't know, had to send it back to HK with a friend to get it fixed won't fix under warranty in China. I am now nervous to try installing IOS 5 on my iPad, it's a USA version with a unicom sim. While surfing on this problem I found a link to this App that supposedly fixes the map offset and it might also work for the map version, once I get my phone back I will try. Someone might want to try it before me to see if it works

    http://www.appgrabber.com/app/china-map-fix
     
  12. lpgn macrumors newbie

    Joined:
    Oct 13, 2011
    #12
    Yes only my one of my IPADS is ok (maps in English)

    What happened and What I did.

    Fist I rushed to upgrade every thing 2 iPhones and 2 Ipad
    I was luck to discover the maps issue before upgrading the second Ipad.
    So I used VPN when upgraded my Ipad, also I chosen to be offline on my Ipad so no location, no sim card and no wifi all times.
    When I tried to restore the Ipad I previously upgraded it works on Pinyin only when I have VPN connected on my IPhones it did not work even with VPN I am going to try a clean install and report later.
     
  13. lpgn macrumors newbie

    Joined:
    Oct 13, 2011
    #13
    My conclusion after many restores are, the maps change to chinese language according to at least 2 variables: the sim card you are using and the IP address location.
    I tested several scenarios and what worked for a brief period was to have a sim from Brazil(not practical) and a vpn all the time, but whenever I either deactivated the VPN, or inserted my chinese Sim it went back to chinese language. This was tested in different restores I tried so I had it working every time but when tying to use it with the chinese sim or without vpn it stopped working.
    My workaround it to start using the web based app from google and place on my home screen. I read something about jail breaking and applying some modifications but did not test it. I also bought a app that I will try a refund called fix maps or something, total scam.
    I didn't try contacting Apple.
    if anyone has a solution I would appreciate it.
     
  14. qti macrumors newbie

    Joined:
    Oct 7, 2008
    #14
    Has anyone found a way to fix this yet? I am having the same problem, not in Google maps but in app store - all the menus (favorites etc.) are now in simp lified chinese when everything else is in English
     
  15. bbolly macrumors newbie

    Joined:
    Nov 9, 2005
    Location:
    London
    #15
  16. RyanSmith20 macrumors newbie

    Joined:
    Oct 16, 2011
    #16
    Can't update Jailbroken iPhone

    I apologise for posting this in here, but i can not work out for the life of me how to create a new topic.

    If someone could point me in the right direction, that would be great.

    My jailbroken iPhone 4 is currently running 4.3.5 (8L1) won't let me update it. If i try to restore the iPhone (via iTunes) or try to update to the new IOS 5 it just says ""The iPhone Joe Blogg's iPhone cannot be restored at this time because the iPhone software update server could not be contacted or is temporarily unavailable""

    Now, I assume that if i am able to unjailbrake my iPhone, then ill be able to just simply update as normal. Ive seen a few threads about SSH or something, not sure what that is, but from what ive read if i havent previously done something with them it makes things harder, well i havent done that with those, whatever they are.

    If someone could instruct the easiest way for me to Unjailbrake my iPhone that would be great

    Again, i apologise for sticking this in here, i couldnt find/create a more appropriate place,

    Thanks

    Ryan
     
  17. BobJenkins thread starter macrumors newbie

    Joined:
    Oct 13, 2011
    #17
    I called apple, was put on hold for a while, and then finally talked to someone in technical support about this issue (the China issue...not the random issue posted above.) What she said it sounds like is that we downloaded the Chinese regional iOS 5 software update. If this is actually the issue (and she was not certain that it is) then here is what she told me to do to fix it:

    1.) Go to library/iTunes/iPhone Software Updates

    2.) In this folder is the .ipsw file that we downloaded which allows us to upgrade to iOS 5 and that we use to restore our iPhones if necessary. If her theory is correct, this should be the Chinese regional .ipsw file.

    3.) Remove this .ipsw file and replace it with one from your home country (or wherever.) She told me to contact a friend or someone from my home country who has an iPhone 4 (it needs to be another iPhone 4, not a 3GS or a 4S), direct them to the this same file in their computer (which, because they aren't in China, will not be the Chinese regional version of this file) and have them send it to me. This part could be kind of difficult because it's an 812 mb file but there are ways to send files this large over the internet.

    4.) Once you have this file from them, replace the .ipsw file you downloaded in China with the one sent from outside of China and then restore your phone.

    (These directions are for mac computers...if you have a windows computer I am sure you can do something similar to figure it out.)

    I am not sure if this will work (neither was she), but this is what she recommended trying at this time. I am still in contact with the apple technical support person still via email and she is bringing up this issue with their engineering team so I will let you guys know if anything else comes up.

    So for anyone who has tried this...any luck yet???

    ----------

    I should also note that I started asking questions about whether using a VPN could influence it at all and she said she isn't allowed to answer any questions about VPNs.
     
  18. lpgn macrumors newbie

    Joined:
    Oct 13, 2011
    #18
    You don't need to ask a friend from overseas here is a link to download the iphone4.0 firmware directly from apple but I doubt this is a solution.

    iPhone 4 [ Link 1 | Link 2 ]

    other models at: http://www.geckoandfly.com/9658/apple-ios-5-direct-download-link-for-ipad-2-iphone-3g-and-4/
     
  19. RobShanghai macrumors newbie

    Joined:
    Oct 14, 2011
    #19
    Yes I agree, I downloaded my IOS5 connected to my UK VPN and made no difference, I don't think there are regional versions of IOS5 it's to do with your SIM and IP address. We need an update on IOS5 to go back to how it was with IOS4 or an option to select Map language or for Maps to follow what is selected in the regional format settings, it's a real pain
     
  20. Estratos, Oct 19, 2011
    Last edited: Oct 19, 2011

    Estratos macrumors newbie

    Joined:
    Oct 11, 2011
    #20
    I think the problem is the location and chinese SIM. Even if you are using a VPN, google maps can find your actual location.

    Try it by connecting to a VPN and going to maps.google.com. The location is still Chinese, even though my IP address is from the USA/UK/NL etc.

    I've downloaded iPhone 4 ipsw files, and although I was connected to the VPN etc, the maps were in Chinese.

    The only thing that worked was a downgrade to 4.3.5. So no iOS5 fun for me, I prefer my English maps and directions.
     
  21. BobJenkins thread starter macrumors newbie

    Joined:
    Oct 13, 2011
    #21
    Hmmmm... ok. I will send the mac technical support person another email asking for other ideas and mentioning the sim card issues you guys have been having.
     
  22. davidmgamble macrumors newbie

    Joined:
    Oct 19, 2011
    #22
    Problem might be the Chinese Government

    I have tried all of the above suggestions and still nothing has worked. I have a feeling that the government has put this restriction on Apple. Having every iOS update with Chinese maps now eliminates Apple's need for a separate iPhone chain of firmware. I'm guessing the only solution is install the iOS from abroad and never bother with updating from inside the mainland. China sucks.
     
  23. RobShanghai macrumors newbie

    Joined:
    Oct 14, 2011
    #23
    Report a bug in Maps app

    I suggest as many as possible report this problem as a bug in the Maps app to Apple to put some pressure on them so it does not get ignored. Go to

    http://www.apple.com/feedback/iphone.html
     
  24. bbolly macrumors newbie

    Joined:
    Nov 9, 2005
    Location:
    London
    #24
    Same problem with everyone - UK iPhone 4, upgraded to iOS 5 in Shanghai and now Chinese map with no Pin Yin. I re-downloaded and restored it under UK VPN and UK SIM in Shanghai with no resolution.

    THEN I landed in Hong Kong today, switched to my Hong Kong SIM card and voila, English maps and Pin Yin Chinese!!! I hope it stays this way when I fly back to Shanghai this Friday.....will report back....
     
  25. davidmgamble macrumors newbie

    Joined:
    Oct 19, 2011
    #25
    Problem solved

    Not sure if it was apples problem or googles, but my maps are now in English, with directions, without VPN. Thankfully the maps are back to the way they should be.
     

Share This Page