I upgraded to new hard drive and my mac recognizes it but it won't boot from it

Discussion in 'MacBook Pro' started by SwissDuckSlayer, Feb 16, 2012.

  1. SwissDuckSlayer macrumors newbie

    Joined:
    Feb 16, 2012
    #1
    Hi, I just upgraded my mid 2009 13" Macbook Pro to a 500 GB hard drive today but since installing it I have had nothing but problems. When I connect it internally it recognizes it in disk utility but when I went to restore it using my time machine back up it failed. So after a couple attempts I tried just reformatting the disk and installing it from snow leopard but it won't format it to osx extended (journaled), it will only format it to FAT using disk utility. It says there was and input/output error. So then i plugged in the same hard disk externally and it worked perfectly normal, so I reformatted it and installed snow leopard and it worked but when I go to replace it in my macbook it doesn't boot from it, it doesn't recognize it as an os. So I'm kinda stuck here. I've looked all over the web and can't find any solutions to my problem. It seems like it's some sort of compatibility issue but it seems funny to me that it would even recognize it if it wasn't compatible. Any help would be great.

    Thanks
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
  3. SwissDuckSlayer thread starter macrumors newbie

    Joined:
    Feb 16, 2012
    #3
    yeah this is where i'm having the trouble. When I go to partition it after doing all the steps and i click "apply" it attempts to do it and then half way it says "input output error". This only happens when i have ther hd connected internally. when i cave it connected externally it works fine
     

Share This Page