I use two iPhones in my life. One shows missed calls for the other. How do I stop this?

Discussion in 'iOS 10' started by audirs5, Jun 20, 2016.

  1. audirs5 macrumors 6502

    Joined:
    Oct 20, 2014
    #1
    Hello,

    I have two phones, 1 for work, 1 for personal. My work phone shows me when I have a missed call from the personal one.. I do not have wifi calling on, or anything like that.. How can I stop this feature???

    Thanks
     
  2. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    I'd guess it's some sort of Apple ID or iCloud syncing "feature".

    The first thing I'd check is the contact that is designated as "My Info" in Settings>Mail, Contacts, Calendars. Does it contain both of your phone numbers and/or email addresses? Try creating a separate contact for your work persona.
     
  3. waitandwait macrumors regular

    Joined:
    Jun 3, 2016
    Location:
    Singapore
    #3
    Settings>Phone>Calls on Other Devices>Allow Calls on Other Devices

    Switch off or on
     
  4. audirs5 thread starter macrumors 6502

    Joined:
    Oct 20, 2014
    #4
    Already off. Like I mentioned, I can't receive or make calls on either device unless it's the respective number.. And add to it, the phone doesn't ring, it just shows when I get a missed call on the primary.
     
  5. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #5
    Is this something that just stated happening with iOS 10 beta randomly (and wasn't happening with iOS 9 or some other earlier version)?
     
  6. Blujelly macrumors 65816

    Blujelly

    Joined:
    Sep 2, 2012
    Location:
    South East England
    #6
    I'd assume as you've posted this in the beta section, it sounds like a bug. Personally its not worth beta, I'd downgrade until the officially version is released.
     
  7. waitandwait macrumors regular

    Joined:
    Jun 3, 2016
    Location:
    Singapore
    #7
    Then I guess it's a telco or SIM card issue.

    I have two phones and split SIM cards. One is set as the "first phone" which receives all the calls and messages. The other only shows I have a call. It cannot make calls or send messages
     
  8. grockk macrumors 6502

    grockk

    Joined:
    Mar 16, 2006
    #8
    This is in old versions of iOS as well. If you share the same iCloud account on both devices you have to turn off iCloud Drive on one of them to get the "missed call sync" to stop. You may also need to disable handoff.
     
  9. audirs5 thread starter macrumors 6502

    Joined:
    Oct 20, 2014
    #9
    This problem persisted even when I did not have the os10 beta... Everything is off, except iCloud.. So, could be that?
     
  10. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #10
    What about iCloud Drive?
     
  11. theshoehorn macrumors 6502

    Joined:
    Jul 6, 2010
    #11
    I have the same issue, same scenario too. I just deal with it, haven't found a way to disable it without using 2 different iCloud accounts... Its been happening for since iOS 9... so not related to the beta of 10...
     

Share This Page