I want my 2011 MBP off the internet. Entirely. For good. No internet.

Discussion in 'MacBook Pro' started by California, Nov 1, 2015.

  1. California macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #1
    I got the 2011 MBP 13" October '11 version that I wanted.

    I want it as a work only word processor. Don't need camera, mic, bluetooth, or wifi/airport. Don't want it.

    Don't want notifications, emails, don't want to be on the internet. I have other Macs for that purpose. I want quiet. I don't want to be tempted to be online on this computer.

    SO, I unplugged the three bluetooth airport brass plugs. Unplugged the airport/wifi/camera cable.

    My 13" MBP was sitting near my other gear and suddenly I get a ping notification on the 13" for an app update. A second later, since I have the same app on another mac, I get pinged there.

    WHAT?

    How is it that I am still on the internet on the 13"?

    So I try to open a Word file.

    Sure enough I get a "Little Snitch" notification that Word is trying to access my computer on Port 2222.

    What is going on?

    Do I have to physically dismantle airport? It is turned off. How can it be accessing the internet or worse, how can Microsoft be accessing my computer? I'm using a licensed version.

    Airport shows "SOFTWARE VERSIONS" under About This Mac. Nothing else is plugged in.
     
  2. macNwindow macrumors member

    Joined:
    Apr 7, 2013
    #2
    Have you tried to go into your firewall and adding the apps (Word/Airpot/Bluetooth, etc.)?

    If that doesn't work, maybe trying to google how to add apps or block ports through terminals. Additionally, you can try to google how to block ports such as 80/443/3389/15/18/20/21.... all of them.

     
  3. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #3
    Sounds like you just unplugged the BT and WiFi antennae? With the antennae unplugged you can still get a signal at close enough range so no guarantee of being off the grid there.

    Did you try <just> turning BT and WiFi off?
     
  4. iBilal macrumors regular

    iBilal

    Joined:
    Apr 14, 2015
    #4
    just turn off the wifi .. uninstall the wifi drivers, etc. ..
     
  5. California thread starter macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #5
    Okay... sounds good thank you!

    http://hints.macworld.com/article.php?story=20020406142423494

    Ancient article on this.
     
  6. California thread starter macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #6
    I thought I did. There is no BT to turn off at this point and WIFI was turned off. Word Microsoft and that other app overrode the fact that WIFI was turned OFF.
     
  7. California thread starter macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #7
    Wifi was turned off... uninstall is what I'm going to have to do... thanks for you guys replying
     
  8. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #8
    Well every Mac I have, if you unplug ethernet and turn WiFi off nothing can get to the internet. Of course Word may still try, but the whole point is Little Snitch sits between the App and the Network, Word can't see the network isn't there so will still try...but it shouldn't succeed - do you have any indication it has? Can you browse the net? does Mail get email?
     
  9. California thread starter macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #9
    Mail is turned off. Haven't tried to surf. But none of that is the point. The point is that without my permission or consent, somehow one of my apps was getting update notification while Microsoft somehow realized I was opening a document...

    IOW there is some internet connectivity going on without my consent.
     
  10. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #10
    Can you perhaps use maybe littlesnitch to block all in and out bound network traffic?
    Maybe make a host file change as well?
     
  11. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #11
    If you turn Wifi off, you're not "on the internet".

    Just do that and be done with it.
     
  12. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #12
    It was turned off
     
  13. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #13
    How could a MacBook, with the Wifi turned off, still be "on the net"?

    Just wonderin'....
     
  14. ABC5S macrumors 68040

    Joined:
    Sep 10, 2013
    Location:
    Florida
    #14
    Since disconnecting the modem in your home while only using the system in question, and turning off the wifi on your system as well, that should do it. Unless you are lazy and don't want to turn off the modem/wifi
     
  15. fisherking macrumors 601

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #15
    really. wifi off, bluetooth off, no ethernet...and you cannot be online. anything else you're seeing, is behavior ON your mac, it cannot be coming from 'online'...if you're not online.
     
  16. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #16
    No, OP said he had disconnected cables, if he only disconnected the antennae then it is still ON and a signal can get through to the electronics if the source is close enough (he also said it was close).

    OP should have left the cables and <just> turned it off. That does it. Here is what he said:



    He may have subsequently turned it off, but then his "test" was that Word tried to access the net, that isn't a valid concern given Word cannot know whether the internet is there or not without trying as Little Snitch is in the way as well...

    He says Mail is off and he hasn't tried to surf. (WTF, the most obvious test). Short of feeding paranoia I can't see what else can be suggested.
     
  17. California thread starter macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #17
    This is what I was wondering, and why I posted.

    The problem is I did all the right things and yet I still got "pinged" by updates for certain apps.

    And then Microsoft attempted access because it "saw" a Word doc had just been opened...
     
  18. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #18


    That was Little Snitch telling you that Word (on your computer), was trying to access the net, you can't stop that AFAIK, but it isn't "Microsoft" (on the net), trying to access your machine.

    You said you unplugged internal cables, that isn't at all "all the right things"...
     
  19. California thread starter macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #19
    The problem was that everything was off but i still got "pinged" by certain apps and then, Word.
     
  20. California thread starter macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #20
    What it was saying was that Word wanted to access my computer through Port 2222. This was right after I was "pinged" with an update from the internet.
     
  21. California thread starter macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #21
    Somewhere I found a link that said this is a backdoor Port 2222 issue; that Microsoft and also bots find this backdoor on Macs somehow.

    Airport was off. Unplugged. One of these links says that what is happening is that Word is broadcasting...

    Let me try to find the links: http://www.speedguide.net/port.php?port=2222 and here:

    http://www.tech-archive.net/Archive/Mac/microsoft.public.mac.office/2005-04/msg00193.html
     
  22. California thread starter macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #22
  23. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #23
    Word is already ON your computer.

    I'm not sure you understand enough to know if you have a problem at all TBH.

    Pulling cables was a BAD idea, initially you stated only that you had pulled cables, I still stand that you had WiFi still turned on at that point and had only pulled the antennae, at close enough range that would still allow a signal through. Word is a red herring, its on your machine not coming from the internet. Apps WILL poll the internet to see if it is there, they don't ask the WiFi, get told WiFi is off and change their behaviour.

    Since to turned WiFi off in the menubar have you had any genuine indication the internet is accessible (last time you hadn't even tried a basic browsing test...).

    OR Your Mac is unique. Wrap it in tinfoil and move on. This is just paranoia.
     
  24. California thread starter macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #24
    Do you know how Little Snitch works? It works with incoming requests. Thanks for trying not to patronize me; I really just asked an honest question.
     
  25. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #25
    Yes I have LS, it wotks on both in and outgoing requests, in the right mode you have to grant apps permission in LS to access the internet, that is what you saw Word doing

    Asking the question isnt a problem, you just need to start taking the answers onboard, otherwise why ask?
     

Share This Page