ibook and Mac OS X

Discussion in 'Mac Apps and Mac App Store' started by ranias, Oct 5, 2004.

  1. ranias macrumors newbie

    Oct 5, 2004
    I just bought an older ibook G3 off someone and along came a Mac OS X CD that is a burned copy of the OS...the guy apprarently didn't have the original CDs for the ibook...so I decided to do a fresh install of the OS...and did a delete and install....but everytime my install finished...I get kernel panic messages when I try to boot my ibook. So a friend gave me Mac OS X for iMac and said I should be able to install the OS from them, but no luck...
    I'm new to Mac OS world, so I'm not sure if the OS is specific to every machine, and I don't even know what should work on my ibook now..
    any advice?
  2. wrldwzrd89 macrumors G5


    Jun 6, 2003
    Solon, OH
    If you get KPs with new Mac OS X installs regardless of the source disk used, odds are that there's a hardware problem with the Mac you're using (in this case, that iBook). Unless you have an Apple Hardware Test CD from another Mac, you're going to have to ask someone else to run the diagnostics on it. The folks at the various Apple Stores can do this for you - go to the Genius Bar.
  3. cluthz macrumors 68040


    Jun 15, 2004
    I have heard that the Imac G5 system cd can't be used on other macs,
    but i haven't tested it myself.
    Older mac system cds can be used on other computers
  4. Doraemon macrumors 6502

    Aug 31, 2001
    Europe (EU)
    While that might be true (I don't know), it's irrelevant since it that case, it wouldn't let you install the OS in the first place.

    As for the Kernel Panics, my bet is on hardware issues, too.
  5. ranias thread starter macrumors newbie

    Oct 5, 2004
    why would it all of a sudden have hardware problems given it was running Mac OS X fine before I tried to reinstall it?
    it was functioning well, I even had an airport card installed in it and it worked fine...
    the Mac OS X I installed was not the imac version...that one would not even start the install...I used the burned copy...so I was susspecting maybe the burned copy is corrupted or something...but why would it let me finish the install all together?
    I also did a disk check/repair while I was trying to do the install...and nothing came back..everything seemed fine.

    what kindda hardware problems could be causing this?

  6. jeremy.king macrumors 603


    Jul 23, 2002
    Fuquay Varina, NC
    What version was it running?

    What version are you trying to install?
  7. ranias thread starter macrumors newbie

    Oct 5, 2004
    I think it was running 9 and 10.2...and I'm trying to install the same one..

Share This Page