iBook doesn´t charge fully

Discussion in 'PowerPC Macs' started by Adrianus, Dec 30, 2008.

  1. Adrianus macrumors member

    Joined:
    Oct 17, 2008
    #1
    I have a second hand iBook G4. It chargers properly until it reaches 50% and it stops right there. It has a replacement battery the previous owner installed before I got it (it isn´t Apple brand), and I only replaced the charger yesterday after it broke. My best guess is that the problem is the battery, because if it had a faulty connection it wouldn´t charge at all. Any suggestions?
     
  2. ftaok macrumors 601

    ftaok

    Joined:
    Jan 23, 2002
    Location:
    East Coast
    #2
    You might want to look up the calibration procedure for the iBook G4.

    Also, it could be that one (or more) of the battery cells is dead.
     
  3. Adrianus thread starter macrumors member

    Joined:
    Oct 17, 2008
    #3
    I looked up the calibration procedure and it says you have to let it charge fully and then etc... Mine doesn´t charge fully at all though. I´m gonna try to calibrate it by letting it charge as much as it can and see what happens.
     
  4. OrangeSVTguy macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #4
    Try holding down command, option, P, R at startup and let it restart a few times while still holding down that key combination. Hold until it cycles at least 3 times.
     
  5. Adrianus thread starter macrumors member

    Joined:
    Oct 17, 2008
    #5
    Ok i tried both of there and neither worked. It just reaches 50% and then it says ´Battery is not charging´. With a 50% charge it lasts me a bit more than 2 hours. Maybe that IS fully charged and it´s just the software acting up?
     

Share This Page