iBook G4 12" A1133 Not Powering Up/Power not Getting to PMU?

Discussion in 'PowerPC Macs' started by Marina Grainger, Jan 5, 2010.

  1. Marina Grainger macrumors newbie

    Jan 5, 2010
    Hi, I've inherited an iBook G4 12". Model A1133. It came with a partially charged battery and a known power issue. Initially with the battery partially charged (on another iBook), the machine turned on ok. The battery was not charging, according to the About this Mac and the Coconut Battery application, although the light on the AC adaptor was amber. As the battery became flat, the iBook was no longer able to be turned on.

    I have reset PMU, PRAM, Opened the Firmware and reset the NVRAM, reseated the battery and tried a host of things suggested on this forum and others to no avail.

    I have also replaced the DC-in board (no difference, so put the old one back in) and tried a different power adaptor.

    The battery is as flat as a tack (now occasionally flashing one light when button is pressed) and now there is no chime, fan noise except for an occasional sound which sounds like the hard drive starting then stopping (very faint sound though) when I try to power up the iBook.

    I was hoping to get an external battery charger to charge the battery as I don't have a spare charged one nor access to a similar working iBook. I live in Australia and have been unable to find one online here.

    The other thing I have heard on two forums, is that this iBook doesn't have a PRAM battery and therefore cannot start without a powered battery in place. If this is the case, then the issue may be that of just the power not being delivered to the PMU?

    At wits end :confused:. Any advise gratefully accepted.

  2. pvmacguy macrumors 65816


    Sep 2, 2009
    Have you tried powering on without the battery in place just running off a/c power? If that doesn't work it sounds like the logic board on that ibook is toast and you should sell it for parts or fix it up. Or if its very poor condition the garbage can.
  3. matthewscott661 macrumors 6502


    Jun 27, 2009
    You are right that the iBook doesn't have a pram battery, at least the 12 inch one i'm sure. It shouldn't affect startup though. I remember being able to start my old iBook without the battery for a week or so when my old one died and I had to replace it (it pained me to pay more than $100 for a battery for a 5 yr old laptop).
  4. Marina Grainger thread starter macrumors newbie

    Jan 5, 2010
    Thanks matthewscott661.

    I am getting power into the battery as the light changes from green to amber when the battery is seated. I am thinking now the problem is two-fold. Dead battery (it's never been changed) and the AC problem so it can run without the battery.

  5. rjphoto macrumors 6502a


    Mar 7, 2005
    have you tried this yet? Take the battery out and try to start it up.

    If that works it's most likely the battery.

    IF it doesn't it may be the charger or the Logic Board... the Green and Amber lights are feed back from the Logic Board. Have the charger checked out by a professional.
  6. Marina Grainger thread starter macrumors newbie

    Jan 5, 2010
    Thanks rjphoto for the suggestion.

    I did try starting it without the battery, it still didn't work.

    I have two charges, both of which work.

    Looks like a logic board issue?

    Has anyone heard of a supercapcitor in the iBook? Could this cause PMU issues?


Share This Page