iBook G4 stopped recognizing my digital camera

Discussion in 'Macintosh Computers' started by wtobiasjr, Aug 24, 2004.

  1. wtobiasjr macrumors newbie

    Aug 16, 2004
    This is a frustrating problem.

    I bought a G4 iBook in June and was using it and iPhoto with my Fuji Finepix 3800 digital camera.

    A few weeks ago, while importing photos, the iBook started hanging. It didn't freeze, but it got hung up after importing three photos and wouldn't import any more. Perhaps rashly, I restarted the iBook. Since then the iBook has not recognized my camera. It doesn't show up on the desktop when attached and it doesn't show up as an attached device in the system profiler. It's as if it weren't attached.

    I've spent hours on the phone with Apple's tech support to no avail.

    A few points: The Finepix 3800 is on the list of cameras compatible with iPhoto. My camera shows up on my girlfriend's iMac running OS 9.1, my G3 at work running 9.2 and a colleague's G4 Mac running OS X, leading me to believe it's not a problem with the camera or the camera's USB cable. I've used my printer with both USB ports, so the problem isn't the ports. Finally, as a last resort, I did a clean reinstall of my system and it still didn't work, leading me to believe it's not a corrupted system file. Just to be sure, I reset my camera to factory settings, removed the batteries overnight, reformatted my memory card and tried it with a different memory card. Nada.

    There are only two things I can think of that I haven't yet tried: I haven't hooked up a different digital camera to see if it recognizes other cameras and I haven't tried hooking my digital camera up to another iBook G4 (although since I used my camera with my iBook for a month and a half, I know they're not incompatible).

    Any ideas? Is this a problem covered by Apple's warranty? Is there anything I should know before trying to bring the iBook in to be serviced?
  2. seamuskrat macrumors 6502a


    Feb 17, 2003
    New Jersey USA
    Part of my posts vanished:

    Your abrupt shut down may have caused iPhoto to loose a preference or some file. Or, some other OS X file may have become corrupted. In theorey, you can trouble shoot the OS and the camera connection.
    A few things to try:

    Boot from CD and repair disk and repair permissions. This should help check the integrity of your system and make sure all is well.

    Next, boot and see if IMAGE CAPTURE sees the camera. Its located in the Applications folder.

    Often when iPhoto is quirky, Image Capture works.

    If IC sees the camera, and you Can import, then you know the problem is iPhoto related.

    And you know you need to reinstall iPhoto. You can do an OS X reinstall of X using the save and restore feature. But its a pain. If you do not have the latest iLife, you can always upgrade it. You could also use Pacifist (shareware) and extract the iPhoto package from the OSX instal disk.

    But try the repairs, permissions and image capture app first.

    If that fails, then verify the connector cable to make sure its not defective.

    Good luck.

  3. stoid macrumors 601


    Feb 17, 2002
    So long, and thanks for all the fish!
    I'm guessing that seamuskrat intended to post something along the lines that you probably corrupted some iPhoto resource when you force shut-down the computer. You should be able to back up your photo library, and erase and reinstall iPhoto off of the iLife disc.
  4. wtobiasjr thread starter macrumors newbie

    Aug 16, 2004
    Thanks for the response. Apple's tech support walked me through the repair disk utility and correction of preferences. I also logged in as a new user and it still didn't work. After that, I first did an archived reinstall (no dice) and then a clean reinstall of my system and software, which would include iPhotoj; it still doesn't work. I don't think the problem is iPhoto based because one would assume the camera should mount on the desktop regardless of iPhoto. As for the connector cables, all I can say is the camera mounts on every other computer I've attached it to.

    My last resort, other than returning my computer to the manufacturer for servicing, is to zero out the disc before doing a clean install of the system. Our Mac consultant tells me that this sometimes fixes persnickety problems that even a clean install can't fix. Any comments before I do the deed?
  5. Macky-Mac macrumors 68030


    May 18, 2004

    this was true in my case. My camera didn't show on the desktop but Image Capture when opened could find it while iPhoto didn't

    So, if you haven't already, I second the idea that you should hook up the camera and open up Image Capture to see whether you can find the camera
  6. wtobiasjr thread starter macrumors newbie

    Aug 16, 2004
    I give up.

    I went ahead and zeroed out my hard drive--several times in fact--and then reinstalled a fresh system and my iBook still fails to recognize the camera. (Image Capture does not recognize it either.)

    Before I bring it into the shop, I need to try attaching other digital cameras to see if this problem is unique to my camera. As I previously mentioned, the problem doesn't appear to be my USB ports (I can print from both of them) and it doesn't appear to be my camera (it works on the three other Macs I've tried it on, each of which is running a different OS).

    Frustrating, frustrating, frustrating.
  7. jeremy.king macrumors 603


    Jul 23, 2002
    Fuquay Varina, NC
    Try formatting your memory card using your camera.
  8. OnceUGoMac macrumors 6502a


    Mar 3, 2004
    I have a similiar, albeit, not so drastic situation. My camera does not mount on the desktop, but iPhoto still recognizes the camera and I can still use it.
  9. wtobiasjr thread starter macrumors newbie

    Aug 16, 2004
    As I mentioned earlier, I've already reformatted my memory card, as well as reset my camera to factory settings, taken the batteries out overnights and tried another memory card. Nothing.

    Seeing as I've reinstalled my system and it still doesn't work, my only guess is that it's some kind of a hardware malfunction. What piece of hardware is in charge of recognizing and booting up digital cameras, I don't know.
  10. Solafaa macrumors 6502a


    Jul 15, 2004
    Daddy said not to talk to strangers
    The problem is not with your camera. You said your camera worked with other mac, in your case i would send it to the nearest mac store and let them check it or try another camera and see if it works.

    This might soung strange but i would take my laptop to the store and try another camera (same modle) and see if it works, if it dose not then you have a problem with your iBook and i hope you have applecare.
  11. RubberChicken macrumors regular


    Sep 16, 2003
    This just happened to me last night using My Pentax Optio S4 and G5. I stupidly turned the camera off after importing, but before unmounting it. I got the warning about possible damage as a result of improper dismount. Next time I put the camera in, it would not show up in either iPhoto or Image Capature and mounted on the desktop looking like a folder. Get Info on the folder said it was a volume. I tryed dragging it to the trash to unmount, but it would not. Stupidly, I turned the camera off again - same warning message. Next time I put the camera in, it did not appear anywhere except Disk Utility, which said it was mounted. I tried reformatting the card using the camera, the G5 still will not see it correctly.

    At home the camera worked just fine on my PowerBook.

    I'll try permissions and disk fix today.

Share This Page