iBook trackpad not functioning...

Discussion in 'Mac Help/Tips' started by kiwi_the_iwik, Mar 15, 2003.

  1. kiwi_the_iwik macrumors 65816


    Oct 30, 2001
    London, UK
    Hi folks...

    OK - a friend of mine brought over his brand-new 14" 800Mhz iBook yesterday. He wanted to use it for video editing, so I partitioned his 30Mb drive 3 ways - OS 9 (2Gb), OS X (15Gb), and VIDEO (11Gb). Of course, I had to re-install the OS's.

    When installing OS 9, I had to put it into the OS X drive first, then clicked & dragged it over to the OS 9 partition - well, it still worked, so I thought I got away with it...

    Anyway - for speed, I used my mouse plugged into his USB port. After booting up and restarting countless times to check the integrity of the OS's, I was satisfied - even after unplugging the mouse and using the trackpad, without any problems.

    This morning, he called up saying that the trackpad doesn't work - his computer is effectively DEAD. However, his keyboard still lights up, and he can boot up and shut down...

    Any suggestions, before I have to go out and buy him a new computer?!?

  2. Gus macrumors 65816


    Jan 1, 2002
    Ok, first, how did his keyboard "light up"? Are you talking about an external keyboard?

    Second, you can just put the OS 9 CD in the drive, startup from the CD, and then when you want to install, select the partition you want OS 9 installed on. Even with the way you have it now, you can just re-install on that 9 partition without affecting the other ones. I would really suggest doing that, and then see if that doesn't help. As a last resort, I would re-install the OS X stuff too.

    Have you tried any of the following:

    1) Boot up holding down the Option key? this gives you the option of which partition to boot from. Maybe you could see if they are both screwy, or if it is just ine or the other.

    2)Terminal Fix

    Boot up in OS X and hold Apple - S. When you get to [localhost]... type in

    fsck -y

    If there are any errors, run it again.
    When the file system check comes back with no errors, hit control - D to continue booting.

    If these don't work, then I am useless. Good luck!

  3. ibookin' macrumors 65816


    Jul 7, 2002
    Los Angeles, CA
    If you're still having problems even after doing what Gus said, take it to Apple and have it fixed under warranty. If the trackpad just died the should be willing to replace it.

    Apple is nice about things like that. I got a new power cord once because the old one got tangled in a sharp object and was cut. :D
  4. kiwi_the_iwik thread starter macrumors 65816


    Oct 30, 2001
    London, UK
    Well Gus - I meant that the Caps Lock & Num Lock keys "light up" on the keyboard, so it was solely a trackpad fault...

    I went around to see him last night to try and remedy the situation (of course, the poor bloke was beside himself!)...

    Definitely a hardware fault.


    * I tried booting up from OSX install disk (holding "C" key at bootup) - no change.

    * Launching in OS9 - still no response from trackpad.

    * Plugged in external USB mouse - cursor moved without any problems.

    * Did Disk Repair & Disk Privileges Repair - no change.

    * Reset computer to factory settings (took out partition, reformatted drive, reinstalled original system software, removed USB mouse) - trackpad still frozen.

    So - he's taking it back to get it replaced. I just hope he doesn't lose confidence with the iBook...

    What I think might have happened was when I partitioned the drive, I had to reinstall the OSX.2 software. Reading the fine print, it said that I had to upgrade the Firmware to the iBook before installation.

    The only query to that point is that the iBook already HAD OSX.2 installed on the Hard Drive BEFORE I partitioned the drive - so to all intents and purposes, the firmware patch had already been installed...

    Do you think my fears were justified, or do you reckon it was just "one of those things"?


Share This Page