iBooks 1.5 "Configuration Error" on iPad 1(5.01, JBed w/ Redsnow 0.9.9b8)

Discussion in 'iPad' started by iPagan, Dec 8, 2011.

  1. iPagan macrumors regular

    Joined:
    May 31, 2010
    #1
    See title. First time I've ever run into this problem.

    First, it won't even download on my JBed iPad. So I downloaded to my iTunes on my MBP, then transferred it over. Upon launching, it always gives me this error, then crashes.

    Tried deleting the app, then re-downloading it, no go. Also tried killing iBooks app icon in the app switch bar at the bottom, then re-launching it, no go, either.

    I am as yet to do a tethered reboot.

    Has anyone here had this problem?
     
  2. iPagan thread starter macrumors regular

    Joined:
    May 31, 2010
    #2
    So 311 views, not one reply??

    I am the only one with this issue??

    Seriously, this is the first time it has ever happened to me.

    Not that I use iBooks that often.
     
  3. iPagan thread starter macrumors regular

    Joined:
    May 31, 2010
    #4
    I did Google. The steps I listed in my 1st post are the suggested solutions, but no go.

    I followed your tip by adding the repo and added the "iBooks Fix" Cydia tweak, but no dice, either. I even did a tethered reboot.

    In the app's description, btw, it clears states that it WON'T work on firmware above 4.3.

    Thanks for the help, though.
     
  4. okwhatev macrumors 6502

    Joined:
    Oct 19, 2005
    #5
    The only way I can figure out to use the new version of iBooks on a jailbroken iOS 5 device without going through hoops is by doing a custom firmware restore using SnowBreeze on Windows. It's a pain in the freakin' ass, yes, but it does fix the rather complicated iBooks problem.

    If you don't mind having two version of iBooks installed, the fix on xsellize repo absolutely does work, but the version of iBooks available when you're booted in jailbreak mode will be 1.3, and if you are booted unjailbroken (like with semiteather) then the new 1.5 version won't crash.

    The SnowBreeze solution just makes iBooks 1.5 work without any fancy double installs. It's the best method, but it's a huge pain just to get iBooks working.
     
  5. rcfa, Dec 17, 2011
    Last edited: Dec 18, 2011

    rcfa macrumors newbie

    Joined:
    Jun 30, 2007
    #6
    Did you try iBooksFix2 ?

    Same issue here. Just installed the iBooksFix2 which is for iOS5, unlike iBooksFix which is only up to 4.3.x

    But respringing doesn't seem to be enough, and I'm not able to do a tethered reboot right now. So I can't say if it will fix the problem, but worth a try...

    When will Apple ever get it that an iPhone is a pocket computer and an iPad is a tablet computer, and that owners have the right to be root on their property?

    Apple making itself into the junk-yard-dog of the carriers ridiculous contracts (if you use data with the iPhone it costs that much, if you use the same data with your computer, it costs much more), and the anti-piracy fanatics isn't going to be useful in the long run. Just imagine how you're going to pass on your library or music collection.... Easy with physical media.

    -----

    OK, now after I was able to do a real reboot, things work with the fix installed. Respringing will not be sufficient, just to let you know...

    That's why I refuse to buy anything non-disposable that has DRM.
    Only thing I use iBooks for is for Apple manuals and various free books for which the copyright expired. A paper book I can read in bright sunlight and I can give it to anyone I care to give it to.
     
  6. jeeepeee macrumors newbie

    Joined:
    Feb 27, 2005
    #7
    I had the same problem, and I guess by blind luck it got solved.
    This is what I did. No clue if it will work for you.

    I installed the iBookFix2 form the custom repo in Cydia.
    Tried to start iBooks after that, but that didn't work.
    This annoyed me so I though no iBooks then.
    Uninstalled iBookFix2 and after that
    tried to uninstall iBooks. That didn't succeed because there was no uninstall 'x' with the wiggeling icon. (Don't no how to call this).
    I rebooted my iPhone, but still no success with uninstalling.
    I then tried to reinstall iBooks from the Appstore over the already existing iBooks. This was possible and it just replaced the old one.

    And voila, it worked. All my iBooks returned and no Apple jailbreak check preventing me from using iBooks. I could even download new ones.

    I don't really grasp the reason why this works, but maybe the iBookFix (re)moved the prefs and reinstalling them created new prefs.

    Good luck with it.
     

Share This Page