iBooks crashing on rMBP under 10.10/10.10.1

Discussion in 'OS X Yosemite (10.10)' started by iamMacPerson, Nov 4, 2014.

  1. iamMacPerson macrumors 68030

    iamMacPerson

    Joined:
    Jun 12, 2011
    Location:
    AZ/10.0.1.1
    #1
    Ok, so I have experienced my first real bug with Yosemite. I was letting someone use my laptop trying to convince them to upgrade to Yosemite when they clicked on iBooks and it popped up with this error:

    Screen Shot 2014-11-04 at 7.40.41 PM.jpg

    They told me and I came over and clicked "Don't Reopen". Then I was greeted with the standard "iBooks quit unexpectedly." I reported it to Apple then tried again. Same thing. I opened up the Console and pulled up the crash. This is the top 1/8 of the crash. I can post the whole thing if needed, but I don't think it would be necessary and would probably be more characters then allowed by the forum.

    Process: iBooks [542]
    Path: /Applications/iBooks.app/Contents/MacOS/iBooks
    Identifier: com.apple.iBooksX
    Version: 1.1 (582)
    Build Info: iBooks-582000000000000~9
    Code Type: X86-64 (Native)
    Parent Process: ??? [1]
    Responsible: iBooks [542]
    User ID: 501

    Date/Time: 2014-11-04 17:04:33.369 -0800
    OS Version: Mac OS X 10.10 (14A389)
    Report Version: 11
    Anonymous UUID: (removed for privacy reasons)


    Time Awake Since Boot: 210 seconds

    Crashed Thread: 10 Dispatch queue: com.apple.BKLibrary.reloadQueue

    Exception Type: EXC_CRASH (SIGABRT)
    Exception Codes: 0x0000000000000000, 0x0000000000000000

    Application Specific Information:
    dyld: in dlopen()
    /System/Library/PrivateFrameworks/CoreFP.framework/CoreFP
    *** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'Invalid parameter not satisfying: _managedObjectModel'
    terminating with uncaught exception of type NSException
    abort() called

    I rebooted (as you can tell). I tried to Repair Permissions nothing came back for iBooks. Verified Disk, everything OK. SMC+PRAM reset didn't help (didn't think it would), and neither did a new user account. Booted in Safe Mode, same issue.

    I'm thinking about doing a complete reinstall although I would prefer not to. I was told to do that by AppleCare but that is always their answer to everything.

    It is worth nothing that I also updated to 10.10.1 B1 and the issue was still occurring. So this isn't just 10.10.1 but also 10.10. Is there anything, anything at all I can try before I reinstall OS X?

    Any help would be greatly appreciated! Thank you.
     
  2. iamMacPerson thread starter macrumors 68030

    iamMacPerson

    Joined:
    Jun 12, 2011
    Location:
    AZ/10.0.1.1
    #2
    Fixed it. No idea what happened, but I used AppCleaner to delete all the backend files and while launching the app rebuilt them, the app still crashed. Luckily, I had done a fresh install of the OS and pulled the iBooks.app file from the app folder. Replaced the old app with the new one and the app launched right away.

    So far no other issues, but I noticed Time Machine isn't backing up many of my newer apps. I have no idea why, but when I restored the backup most showed as damaged and forced me to reinstall them. One of the apps was even from the App Store! I have no idea whats going on but I'm Zeroing my backup drive and starting a fresh Time Machine backup.
     

Share This Page