iCloud Contacts Not Syncing

Discussion in 'iPhone' started by rhwd2003, Oct 12, 2011.

  1. rhwd2003 macrumors newbie

    Joined:
    Oct 8, 2011
    #1
    So I have been using the developer ios5 for a while and been backing up to icloud. But for some reason now my contacts do not backup. I bought 10gb more of storage so im at 15gb and I have contacts on to sync. But they aren't showing up. Anybody having similar problems?
     
  2. GeeSixx macrumors regular

    GeeSixx

    Joined:
    Sep 27, 2011
    Location:
    California
    #2
    Try hitting the refresh arrow in the top left corner of your contacts. Did it work?
     
  3. rhwd2003 thread starter macrumors newbie

    Joined:
    Oct 8, 2011
  4. Codepiink macrumors regular

    Joined:
    Jun 24, 2010
    Location:
    Westchester County, NY
    #4
    Mine isn't working either. I never had the iOS5 GM, I got the OS today through iTunes. :(
     
  5. thebassman78 macrumors newbie

    Joined:
    Oct 15, 2011
    #5
    The basic solution is to go to your iCloud settings on the iPhone. Disable contact syncing. Allow for the contacts to be deleted. And then enable contacts to sync again. More info on iCloud contacts not syncing can be found here.
     
  6. Gpsmith macrumors newbie

    Joined:
    Oct 14, 2011
    Location:
    UK
    #6
    I think there are other issues here. I have differing numbers of contacts on my iMac, iCloud.com and iOS (two iPad, and iPhone 4s).

    I am finding that contacts that are missing that if I edit them on the iMac the iOS devices shortly (few secs) after gives the swirling indicator within the contacts app to show it's communicating with the servers. However the contact does not appear!

    At first my random syncing issue I thought was linked to capacity, now I wonder more if it's a bug.

    FYI: https://discussions.apple.com/message/16371971
     
  7. augratin macrumors newbie

    Joined:
    Oct 21, 2011
    #7
    same problem here. four different devices (two iphone, two ipads) all supposedly syncing with icloud and all with different numbers of contacts on them.
     
  8. sharpie88 macrumors newbie

    Joined:
    Oct 9, 2012
    #8
    This really helped. Thanks so much for posting! ;-}
     
  9. JCfromTB macrumors member

    Joined:
    Sep 27, 2012
    Location:
    Tampa Bay, FL
    #9
    An easy work-around is to set up an Exchange account for only your contacts...

    I use Gmail Contacts as my primary... so I set up Gmail on an exchange (I use the Gmail app for email) and set it to only sync my contacts and calendar. Works like a charm.
     
  10. lookn4wifi macrumors regular

    lookn4wifi

    Joined:
    Sep 18, 2012
    #10
    I added an email address to a contact, which never showed up on my Mac. Thought it was odd and just me.
     

Share This Page