iDVD unexpectedly quits. . .trying to make me upgrade??

Discussion in 'Mac Apps and Mac App Store' started by houmac, Jan 19, 2004.

  1. houmac macrumors newbie

    Jan 19, 2004
    I loved iDVD2 and was excited to start using iDVD3 (I was less excited when I saw iDVD4 came out two months later, but that's another topic. . .)

    Every time I start the burn, iDVD "unexpectedly quits" about 15 minutes through the menu rendering process. I'm using Apple DVD-R's, so I don't think the media is the problem, and I've tried several different disks. I have an 73 minute movie and a slideshow, so I'm under the 90 min. limit. I've re-installed the software -- all to no avail. It's happened at least 8 times.

    It's very frustrating, and I've got various friends and relatives breathing down my neck for a copy of the 2003 year-in-review movie!

    Of course, I'm kidding about the "trying to make me upgrade" part, but I'm getting so frustrated, I'm running out of other options.

    I would be extremely appreciative of any advice you can offer!
  2. 7on macrumors 601


    Nov 9, 2003
    Dress Rosa
    Repair Permissions
    Can you burn DVDs through Finder or Toast
    Try deleting the
  3. Horrortaxi macrumors 68020


    Jul 6, 2003
    Los Angeles
    What kind of Mac do you have?
    Do you have an Apple Superdrive?
    Have you successfully burned DVDs on this computer using iDVD before?
  4. houmac thread starter macrumors newbie

    Jan 19, 2004
    I have an iMac G4 with the apple superdrive. I burned lots of DVDs with iDVD2, but this is the first time I've tried to use iDVD3.

    I appreciate the replies.

Share This Page