Illustrator + 3D = Mess?

Discussion in 'Mac Apps and Mac App Store' started by GigaWire, Mar 6, 2004.

  1. GigaWire macrumors 6502

    Dec 25, 2001
    Check out this Illustrator CS picture. All i am doing is Effect->3D->Bevel & Extrude on a rectangle. does anyone else get these left over wireframe lines when you change the rectangle's position?

    Attached Files:

  2. cb911 macrumors 601


    Mar 12, 2002
    BrisVegas, Australia
    whoa. looks weird. i don't know about that, but you could probably try at an Illustrator specific forum as well. they would probably be able to help you out alot more there.
  3. Phazer80s macrumors regular

    Jul 25, 2002
    Above the 49th
    Them darn lines!!!

    Sure do! The lines are there to show you the original orientation of your rectangle. They're a reminder that your object is still in an editable (and recoverable) state. You can get rid of the lines by going to the Object menu and choosing Expand Appearance. Expanding an object's appearance will set the transformation permanently... well, more 'permanently' than the state it was in before. It's a bit like 'rendering' your object in a 3D program.

    Hope this helps. :)
  4. Sparky's macrumors 6502a


    Feb 11, 2004
    Very simple, go to "Views" > Hide edges.
    Or "Command + H"
  5. mangoduck macrumors regular


    Oct 26, 2002
    lost at sea
    no, i believe he means the black shrapnel on the right side. it looks like artifacts that aren't being redrawn over with white. don't know the cause.

    does it go away after you apply the transformation (or is there an "apply")? does scrolling it off the screen and back, or dragging another object over it erase it?
  6. Sparky's macrumors 6502a


    Feb 11, 2004
    Oh, I thought the blue keylines.....(running to do more research)...Let's find out!!

    OK what I did was to try and re-create what you created. I drew a box then drew a circle in the box and made the 2 a compound path. I then went to effects>3D>extrude & bevel, chose the default settings and said OK. I then went back to effects>3D>Rotate, and after agreeing to the execute this effect warning I saw the same black ghost lines like in your sample.
    >> I then hit "Command + Y" to see if the "Outline" view would show any of the black lines NONE. Then when I went back to "Preview" the black lines had disappeared.

    Try that and see if they don't go away!!

    Maybe a little bug that Adobe needs to resolve in the redraw of the program.
  7. GigaWire thread starter macrumors 6502

    Dec 25, 2001
    They pretty much stay unless you perform some action that requires Illustrator to redraw. Then they go away. I am leaning more to it being a redraw bug with Illustrator as there is no rhyme nor reason to the stray wireframes.

    But I am glad its not just some bogus issue on my machine alone.
  8. RubberChicken macrumors regular


    Sep 16, 2003
    I'll try not to turn this into a rant about the demise of Diemensions, and its hidious rebirthing in Illustrator CS. It cannot do half the things I used to do in Dimensions, I'm not sure why they bothered. Surely would not have been much more work to port the whole thing. A few bits and pieces... that force me to keep classic going. Grrr.

    Sigh... Annnnnyyway I was evaluating a try out on Friday night, but i don't have a copy at hand. Do you get a better result applying the rotation at the same time as the extrude? I seem to remember applying the rotate after screwed up some of my samples.

Share This Page