I'm Dumb, I really effed up. Can't Roll Back.

Discussion in 'macOS High Sierra (10.13)' started by theturtle, Aug 12, 2017.

  1. theturtle macrumors 6502a

    Joined:
    Aug 3, 2009
    #1
    I unfortunately have made the dumb mistake of installing the beta on my personal comp.

    To be fair, it worked perfectly fine...till now. Last night, the comp was installing the new update. When I woke up, the laptop would not boot successfully. It would have the start up progress bar, then say installing, then it would say "installation error. Please hold D to check disk" or something on those lines. When I hold D during start up, all it would do is take me to a list of languages saying the readme is missing.

    I then formatted the APFS partition and tried to do a fresh install of High Sierra. After I came back, the comp. was showing an error message. At that point, I tried command R to just go back to Sierra. When I went into terminal to delete everything to start fresh, there were two drives, a APFS and the original SSD name. I tried to delete the APFS but couldn't. I then tried to delete the other drive but got an error. I followed some directions I found online:
    http://www.techrepublic.com/article/how-to-revert-back-to-apples-hfs-from-apfs/

    But that doesn't work at all. I also have like 20 drives listed when i do diskutil list.

    Could someone help? And yes, I'm a big idiot for doing this on my main comp.

    http://imgur.com/a/4jRId
     
  2. blackdogaudio, Aug 12, 2017
    Last edited: Aug 12, 2017

    blackdogaudio macrumors regular

    blackdogaudio

    Joined:
    Aug 17, 2016
    #2
    Boot into Internet Recovery (Shift-Option-Command-R), choose Disk Utility to repair, erase and format your drive then install the original operating system that came with your Mac. If you have a fusion drive and it's corrupt, Disk Utility will highlight it in red and offer to repair it. Choose that option to repair it.

    You can upgrade macOS afterwards and reinstall your apps and data from a backup.

    https://support.apple.com/en-us/HT204904
     
  3. Erdbeertorte macrumors demi-goddess

    Joined:
    May 20, 2015
    #3
    I have experienced that installing High Sierra on an already APFS formatted empty drive does not work, it has to be HFS+ for a clean install.

    Also Disk Utility wasn't able to format/convert the drive back to HFS+ and I had to use the diskutil command in the Terminal to do this.
     
  4. theturtle thread starter macrumors 6502a

    Joined:
    Aug 3, 2009
    #4
    Did you have a website that you followed? I'm absolutely having a terrible time trying to figure out why I can't delete the APFS drive. I'm legit running out of options.

    I thought, hmm, maybe I can make a Macintosh HD under the "Apple SSD" drive and then after installing Sierra go in Disk Utility and delete the AppleAPFSMedia drive but nope. I can't even create anything under Apple SSD.

    I tried deleting the AppleAPFS but the problem is, the only erase option it gives me is to make a new partition immediately after deleting so I can't just delete it and be done with it.
     
  5. Erdbeertorte macrumors demi-goddess

    Joined:
    May 20, 2015
    #5
    I sadly can't remember what I exactly did. Started with "diskutil list" from the recovery partition and after that just "diskutil" to show up all possible commands. Somehow I managed to get my SSD back to JHFS+ after trying many things.
    You always get help from diskutil if a command does not work because you have to unmount the drive before or missed some parameter for example.

    You could also try it with the already mentioned "Shift-Option-Command-R" to get into Internet Recovery.
    With Shift in addition to the other keys it loads the latest OS version recovery your Mac came with. And if that version is older than Sierra, there is no APFS and you might be able to just use Disk Utility to format your drive.


    Edit: Just ignore the many small drives shown in diskutil list. I don't know what they are exactly for but they are only visible in Recovery since El Capitan I think. You don't have to do anything with those.
     
  6. blackdogaudio, Aug 12, 2017
    Last edited: Aug 12, 2017

    blackdogaudio macrumors regular

    blackdogaudio

    Joined:
    Aug 17, 2016
    #6
    Just to add...if you opt for Internet Recovery, follow through with downloading and installing the original OS while in Internet Recovery as the firmware upgrade integrated within the High Sierra package appears to be buggy if you roll back to an older operating system.

    On my late 2014 5K, iCloud preferences showed "Find My Mac" greyed out and disabled with an error message stating my firmware was corrupt after a operating system roll back using a TM backup or the latest version of macOS from Internet Recovery (option + cmd + R). No documented repair for this Find My Mac/firmware issue from Apple fixed it either. Only repairing my fusion array while in Internet Recovery and reinstalling my original OS (Yosemite) using "Shift-Option-Command-R" would fix the firmware issue.

    After Yosemite installed, I downloaded and installed a fully copy of Sierra. Everything was completely back to normal including Find My Mac afterwards.
     
  7. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
    #7
    Fastest way out of your problem:

    Go to eBay and buy a USB flash drive that has either Sierra or El Capitan pre-installed.

    Boot from it and re-initialize the internal drive.

    Then do a clean install onto it.

    Then restore your data from your backup.

    That should do it.
     
  8. oatman13 macrumors regular

    Joined:
    Feb 14, 2013
    #8
    From Recovery
    diskutil eraseDisk JHFS+ "Macintosh HD" disk0s2
     

Share This Page