I'm not sure what happened, but suddenly no music!!

Discussion in 'iPhone' started by yalag, Aug 13, 2008.

  1. yalag macrumors 65816

    Joined:
    Nov 18, 2007
    #1
    I'm not sure what happened, but probably related to pwnage/cydia but all of a sudden today my ipod app in my iphone 3g says there no music!! I even tried resync all the music from scratch but still no music! How to fix??
     
  2. mcdj macrumors 604

    mcdj

    Joined:
    Jul 10, 2007
    Location:
    NYC
    #2
    look in itunes. the "sync music" option probably got unchecked.
     
  3. yalag thread starter macrumors 65816

    Joined:
    Nov 18, 2007
    #3
    no....I have already resync my music three times (check and uncheck it)
     
  4. ubersalad macrumors 6502a

    Joined:
    Feb 26, 2008
    #4
    Genius: Have you tried restoring?
     
  5. nickspohn macrumors 68040

    nickspohn

    Joined:
    Jun 9, 2007
    #5
    Did you uncheck the sync music button, and then synced? That way there should be no songs on the iPhone at all.

    Then hit it again, and watch if it says in iTunes that the songs are transferring over. If they aren't, do a restore, and it should fix it.
     
  6. HawaiiMacAddict macrumors 6502a

    Joined:
    Dec 28, 2006
    Location:
    On one of my Macs of course
    #6
    Aloha yalag,

    I noticed that you mentioned Cydia - that means you have jailbroken your iPhone, but that really shouldn't matter (other than some people who probably attribute any issues on a jailbroken iPhone to the fact that it's jailbroken :D). I've experienced the same issue as yourself, on a non-jailbroken iPhone 3G, and it's literally driving me up the wall.

    Here's a follow-on question. What about your non-Apple apps (to include the Apple Remote app)? Once this happens on my iPhone, none of them run - they ALL crash. When I hook up my iPhone to a computer and check iTunes, all of the iPod and iPhoto content is there, on the iPhone, but for whatever reason the iPhone is unable to display it. When I last took my iPhone to the Genius Bar at my local Apple Store, they told me that an .xml file, resident on the iPhone, is corrupt, but offered no way to troubleshoot the issue.

    To make matters worse, at least for me, they actually insinuated that I was doing something wrong when I synced my iPhone with my Mac! It's not rocket science - we sync the iPhone 3G exactly like we did the 1st gen iPhone. I'm now on my 3rd iPhone and the same issue just cropped up again.

    This issue is really driving me insane. I picked up my new iPhone, took it home, set it up as a new phone, then synced my music, video, photos, ringtones, and applications (I set up MobileMe syncing for my contacts, calendars, and bookmarks). Everything was fine last night, but this morning, immediately after I applied the 2.0.1 firmware update, this same issue reared its rather disgustingly ugly head yet again! All of my iPod and iPhoto content was not listed, and all of my non-Apple apps crashed. I, personally, think it's somehow related to the 2.0.1 firmware, but I'm not sure.

    At this point, I have no solution to offer you - only my sympathy, as I'm going through the same situation as yourself. I'll most certainly pass on any information I get from my local Apple Store. I'm at the point where I'm going to just take my MacBook Pro, my external drive (on which I host my iTunes library), and my iPhone into the Apple Store so that they can assist me in the troubleshooting process.

    :apple:HawaiiMacAddict
     
  7. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #7
    This is happening to a lot of people regardless of whether the phone is jailbroken or not. Check out the help forum and you can find the threads. The last time I looked there was discussion on whether it was iTunes or 2.0.1 firmware. Most people do a restore, but I think there are some other ways to recover. Your iTunes will show the phone full of songs, but there is no music/videos on your device.
     
  8. stevoeddz macrumors member

    Joined:
    Feb 18, 2008
    #8
    this happened to me back on my first gen iphone when i installed an app that let you sync to more than one music library at once... i forgot what its called. anyway, in itunes, it said i had about 5 gb of files in the "other" category.

    just restore and resync all your files.
     
  9. Warbrain macrumors 603

    Warbrain

    Joined:
    Jun 28, 2004
    Location:
    Chicago, IL
    #9
    I just had this happen today. A restore did the trick for me.
     
  10. yetanotherdave macrumors 68000

    yetanotherdave

    Joined:
    Apr 27, 2007
    Location:
    Bristol, England
    #10
    I've had to restore twice with this problem. Both times the problem occoured when I was installing an app in the app store application on the phone. Straight after installing, none of my apps would open and all the music/podcasts were gone.

    Restore phone and restore from the last backup fixed it for me.
     
  11. HawaiiMacAddict macrumors 6502a

    Joined:
    Dec 28, 2006
    Location:
    On one of my Macs of course
    #11
    Aloha everyone,

    I realize that a restore will do the trick, but why should we have to do a restore that often? I literally had to do a restore ONE day after receiving my new iPhone 3G - as a matter of fact, after having synced it once then upgrading to firmware 2.0.1. Which file is getting corrupted and how can we solve this issue - that's what I'd like to know. The Geniuses made it sound as if it was only my problem. In hindsight, maybe I should've seen what everyone else was saying about this issue.

    HawaiiMacAddict
     
  12. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #12
    Agreed. I trust that a future fix will address the issues. For now, backup backup backup.
     
  13. Warbrain macrumors 603

    Warbrain

    Joined:
    Jun 28, 2004
    Location:
    Chicago, IL
    #13
    It just happened again to me. I think I'm going to downgrade to 2.0 and not deal with this.
     
  14. Warbrain macrumors 603

    Warbrain

    Joined:
    Jun 28, 2004
    Location:
    Chicago, IL
    #14
    And it happened again today for the third time in 24 hours. This sucks.
     
  15. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #15
    Yup. Last night after an application upgrade (direct to phone, not iTunes) and then today for no reason. bleh
     
  16. HawaiiMacAddict macrumors 6502a

    Joined:
    Dec 28, 2006
    Location:
    On one of my Macs of course
    #16
    Aloha everyone,

    I guess we'll just have to wait until the next firmware update for any sort of resolution, assuming one is forthcoming. I just had to do a restore last night, and after restoring to a backup (not once but twice :mad:), I experienced an interesting twist. All of my 3rd party apps worked, but my iPod contents were still gone. All I had to do at that point was to simply check the boxes and apply the changes to get the content back on my iPhone. Yes, this is rather annoying, but I'll gladly go through this garbage, even on a somewhat regular basis if need be, to be able to continue to use my iPhone 3G.

    :apple:HawaiiMacAddict
     

Share This Page