I'm officially pissed off (old phone has no service, new iPhone 4S is a brick)

Discussion in 'iPhone' started by bollweevil, Oct 14, 2011.

  1. bollweevil macrumors 6502

    Joined:
    Feb 1, 2008
    #1
    I ordered a black 64 GB iPhone 4S from Apple.com, for use on AT&T. It arrived this morning at 9:15 AM EDT.

    My prior phone is an iPhone 3GS, also on AT&T. It is just over 2 years old.

    After many attempts to activate the 4S, at about 4:30 PM, my 3GS lost its service. I now have no working phone.

    I just spent one hour in an AT&T store. Prior to that, I spent one hour on the phone with AT&T. I feel kind of bad for the various AT&T employees who were all unable to help me. I was very polite, so it was very difficult every time one of them got to the point where they said, "there is really nothing I can do, you might as well leave the store / hang up the phone, unless you want to hang out with me for some reason."

    My 4S is slightly more interactive than a brick. I can type in my billing ZIP code and the last four digits of my SSN, and then I can watch a spinny wheel, and then I can read an error message. I cannot get to the home screen, there are no apps, there is no Siri to comfort me.

    My 3GS works fine, but it can't make or receive phone calls.

    I am officially pissed off.
     
  2. iKidWare macrumors member

    Joined:
    Oct 7, 2011
    #2
    yeaaa same here bro,,,, i loved waiting for hours on a pre order to pop up,then a reservation,then a confirmation,then a week,now a llooonnngg 3 minute activation, lol i have 2 iphone 4s in front of me,taking turns trying to activate lol....
     
  3. amann76 macrumors 6502

    amann76

    Joined:
    Jun 16, 2009
    Location:
    MacWorld USA
    #4
    new phone hasnt got here yet old phone cleared everything off to prepare it to sell... need to send a text or two or three and cant
     
  4. mikethebigo macrumors 68000

    Joined:
    May 25, 2009
    #5
    I'm officially with you as far as pissed-offedness goes.

    Every year I say, this is the last time, AT&T. I need to actually act on that sometime.
     
  5. Elven macrumors 6502a

    Elven

    Joined:
    May 13, 2008
    Location:
    UK
  6. bollweevil thread starter macrumors 6502

    Joined:
    Feb 1, 2008
    #7
    To be fair, a tech support person at AT&T's national call-in center took my phone number, AT&T account number, 4S serial number, IMEI, and SIM card number, and promised to email me back later. Oh, they took my email address, because I have no phone.

    They also said that it may start working spontaneously, and I should try rebooting the phone and retrying to activate it every hour or so. If I feel like it.
     
  7. bollweevil thread starter macrumors 6502

    Joined:
    Feb 1, 2008
    #8
    Fixed. That only took 27 hours.

    So, I went back to the AT&T store today (Saturday, after receiving the phone Friday), and we called AT&T national tech support together. They asked for the IMEI and SIM card number... again. Then they said, "oh, well of course your phone doesn't activate, the numbers in the system are all wrong." And they fixed it.

    Well, that was a hassle.
     
  8. Young Spade macrumors 68020

    Joined:
    Mar 31, 2011
    Location:
    Tallahassee, Florida
    #9
    So is your phone fixed now? But that's weird that it happened; I turned my phone off, called the numbers, and got the phone activated. Turned the phone on 5 minutes later, and proceeded to use it.

    I definitely called the local AT&T store though to make sure I did everything correctly.

    But I think the moral of this story is that representatives have no idea what they are doing, or do not care.
     
  9. bollweevil thread starter macrumors 6502

    Joined:
    Feb 1, 2008
    #10
    Yeah, my phone is totally fixed now.

    I think that yesterday the AT&T people were just totally overwhelmed by calls, because it was launch day. Today, I got through to a tech support person on the phone (the AT&T store's phone, because I had no working phone). I was only on hold for like one minute, and they fixed it within 5 minutes.
     
  10. Young Spade macrumors 68020

    Joined:
    Mar 31, 2011
    Location:
    Tallahassee, Florida
    #11
    Ah, yea that's good; yea it got sent to my house on Friday and had to get it overnighted to me today. I got it, called, and had it working within 20 minutes of receiving the phone.

    Glad I made the jump too; this is a really cool device.
     
  11. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #12
    Starting to think it's just as well that my upgrade eligibility date isn't for another 2 weeks :) Should be a smooth process by then!
     

Share This Page