iMac 27'' with dual monitor question..? (Starcraft 2)

kraigballa

macrumors newbie
Original poster
Aug 1, 2010
21
0
Alright just like the title says...I have an iMac 27'' with a 27'' hp monitor. I have a mini-display to vga adapter that I use to hook up the hp monitor to my iMac. My problem is that when I try and play Starcraft 2 it automatically puts the game on my iMac screen, but I want it on my hp screen. The game starts in full screen so there are no options to try and drag it over. In the game itself I can make it windowed and bring it over, but then on the hp it is not full screen. So when it is on the hp I go back to options and change the display back to fullscreen and the game goes back to the iMac and leaves my hp with a blank black screen. How can I make it so that I can play Starcraft 2 on my hp monitor while still having my normal desktop open on the iMac...?

Thanks for your help!!
 

xraydoc

macrumors demi-god
Oct 9, 2005
7,739
1,885
192.168.1.1
Alright just like the title says...I have an iMac 27'' with a 27'' hp monitor. I have a mini-display to vga adapter that I use to hook up the hp monitor to my iMac. My problem is that when I try and play Starcraft 2 it automatically puts the game on my iMac screen, but I want it on my hp screen. The game starts in full screen so there are no options to try and drag it over. In the game itself I can make it windowed and bring it over, but then on the hp it is not full screen. So when it is on the hp I go back to options and change the display back to fullscreen and the game goes back to the iMac and leaves my hp with a blank black screen. How can I make it so that I can play Starcraft 2 on my hp monitor while still having my normal desktop open on the iMac...?

Thanks for your help!!
Sounds like the game defaults to the MacOS's main screen (the one with the menu bar and the dock).

One work-around would be to go to the Displays system setting and move the menu bar to the HP display, then run the game. It'll at least appear on your external display, though you wont have access the menu bar & dock while it's running (I suspect the game's programmers didn't account for people wanting to do this).
 

kraigballa

macrumors newbie
Original poster
Aug 1, 2010
21
0
Sounds like the game defaults to the MacOS's main screen (the one with the menu bar and the dock).

One work-around would be to go to the Displays system setting and move the menu bar to the HP display, then run the game. It'll at least appear on your external display, though you wont have access the menu bar & dock while it's running (I suspect the game's programmers didn't account for people wanting to do this).
I did what you said and it does work now...the good thing about switching the dock is that when I click on something that is on the iMac the dock lights up on the hp screen, and disappears when I click back on the hp screen.

Thanks so so much!!!
 

Mollo

macrumors newbie
Oct 5, 2010
1
0
Dual Full Screen Mode

I tried what u suggested with WoW Game xraydoc. Did not work, it even distorted mouse position on my iMac Book Pro; Any other suggestions?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.