iMac 5K Late 15 / El Capitan / No Wifi after sleep

Discussion in 'iMac' started by zerozoneice, Nov 14, 2015.

  1. zerozoneice macrumors regular

    Joined:
    Jun 26, 2013
    #1
    As the title goes, i don't have wifi connection after Mac wakes from sleep.
    Sometimes it's disconnected, sometimes is connected but doesn't do traffic and needs OFF/ON cycle to reconnect to router and rx/tx data.

    Same router, same 5GHz network, worked fine with a rMBP. So it must be something iMac related.
    Anyone have this or have any idea how to solve? Thx!
     
  2. ZMacintosh macrumors 65816

    ZMacintosh

    Joined:
    Nov 13, 2008
  3. dud3tt3 macrumors newbie

    dud3tt3

    Joined:
    Oct 22, 2015
    Location:
    Melbourne
    #3
    i've had this issue happen on my early 2105 13" rMBP. Not sure why it happens..seems to be random for me. A reboot always fixes it....I have an Asus RT-AC68U router. It's not happened at all on my new late 2015 27" retina iMac though.
     
  4. zerozoneice thread starter macrumors regular

    Joined:
    Jun 26, 2013
    #4
    tplink. nothing to do with the router, on the rMBP i never had issues.
    after researching a bit, it seems it's a widespread issue among apple rMBP/Imac hardware, not fixed in current capitan build.

    i added a new location, as described in this article and so far it seems ok.
    http://osxdaily.com/2014/04/24/fix-mac-disconnect-wifi-sleep/

    just google "imac retina no wifi after sleep" and you'll get the idea.
     

Share This Page