iMac CPU Fan problem!

faneos

macrumors member
Original poster
Jul 26, 2012
80
60
When I start my iMac CPU fan run at full speed istat menus shows 0 rpm temperatures and and everything else seems normal I did a SMC reset problem stays I tried a SMC reset again and i will leave the machine off all night and i open it in the morning anyone have an idea whats wrong?:(
 

faneos

macrumors member
Original poster
Jul 26, 2012
80
60
I am unemployed now no money for apple store.There is a chance of defected cpu fan or software related error or anyone has an idea??
 
Last edited:

Dadioh

macrumors 65816
Feb 3, 2010
1,120
27
Canada Eh?
I am unemployed now no money for apple store.There is a chance of defected cpu fan or software related error or anyone has an idea??
It may be the PRAM that you need to reset, rather than the SMC. See instructions below. Basically unplug power cord, hold power button on for a few seconds, release power button, plug power cord back in, and hit power button to start. I believe that fan controls are stored in PRAM.

http://support.apple.com/kb/HT1379
 

faneos

macrumors member
Original poster
Jul 26, 2012
80
60
I read a solution to remove the motherboard battery to reset it what your opinion ?
 

Dadioh

macrumors 65816
Feb 3, 2010
1,120
27
Canada Eh?
I read a solution to remove the motherboard battery to reset it what your opinion ?
I believe pram reset achieves the same thing and you don't have to open up the iMac. I assume the idea of removing the motherboard battery is so that the info concerning the fans and temp sensors is cleared. Pram reset does that.
 

lexvo

macrumors 65816
Nov 11, 2009
1,222
370
The Netherlands
I had a similar problem, turned out that the temperature sensor of the HDD was broken (even though iStat reported CPU fan). The HDD needed to be replaced to fix this (luckily I have AppleCare).