Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

iMac fusion boot camp trouble

pugxiwawa

macrumors member
Original poster
Nov 10, 2009
93
95
Hi, I'm hoping someone here had experiences and knows how to fix this. I'm running out of ideas. I have a late 2015 27" with 2 TB fusion drive, running Catalina. I had previously installed Windows 10 partition using boot camp and that worked fine, but I ran into issue with Windows 10 GPU driver with Minecraft so I decided to re-install. I used Boot Camp Assistant to remove existing boot camp drive, and I could see the boot camp drive was removed but Boot Camp Assistant reported that is was not able to cleanly remove the partition, asked me to run First Aid using Disk Utility. I ran Disk Utility and got the error saying "invalid key order...Fusion data structures are invalid. The volume /dev/rdisk2s5 could not be verified completely". /dev/rdisk2s5 is the partition where boot loader resides. It seemed that Boot Camp Assistant had only partially removed the boot camp partition but in the process corrupted the boot loader. I tried booting into internet recovery and ran First Aid but go the same result. I also tried running Boot Camp Assistant again to create the partition but that failed as well. Not sure what to do, trying to avoid having to wipe off disk clean and do a complete re-install. No issue with Mac OS though, I can boot into Mac fine so it's just the issue with boot camp partition. Thanks for your help.
 

Attachments

  • Screen Shot 2020-07-19 at 1.45.21 PM.png
    Screen Shot 2020-07-19 at 1.45.21 PM.png
    339.6 KB · Views: 41
  • Screen Shot 2020-07-19 at 1.44.30 PM.png
    Screen Shot 2020-07-19 at 1.44.30 PM.png
    994.2 KB · Views: 20
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.