iMac on Mavericks shows connected to WiFi but no Internet Connection

Discussion in 'OS X Mavericks (10.9)' started by chadnikk, Jul 20, 2014.

  1. chadnikk macrumors newbie

    Joined:
    Jul 20, 2014
    #1
    Hello all,

    I have researched the issue that I am having and it seems as if others are having similar issues. I have a Mid-2011 27 inch iMac and I upgraded to Mavericks in May. Ever since upgrading to Mavericks, I have been experiencing issues with the WiFi connectivity. The WiFi icon shows all full signal. It will work for a while, but the connection intermittently disconnects (still showing full signal to the wireless router). From another post with similar issues, the user advised to right click on the WiFi icon, and turn off WiFi and then turn it back on. This trick works every single time to reinstate my connection. However, I have to do this at least every 5 minutes. Sometimes even more often than that. Here are the specs on my system:

    27-inch, Mid 2011 iMac
    Processor: 2.7 GHz Intel Core i5
    Memory: 4 GB 1333 MHz DDR3
    Graphics: AMD Radeon HD 6770M 512MB
    Software: OS X 10.9.4 (13E28)

    Is there a fix for this issue? I have searched for resolutions, but haven't had any luck so far. I have Mavericks on my 2009 MacBook and have no connectivity issues. Please advise me on any tips that you may have to resolve this issue. I really appreciate your time!

    Chad
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    1. Reset NVRAM / PRAMM.


    2. Turn off wireless. Go into the application /Applications/Utilities/Keychain Access and find the entry for your non-working setting and delete it. Then turn your Airport card back on and rejoin your wireless network.


    3. Open System preferences->Network pane, Advanced button and click on the 'Renew DHCP Lease' and see if you get all the network settings, including the 'DNS' mini-tab. If you get no DNS settings use either OpenDNS or Google Public DNS and put those IPS in the DNS mini-tab.


    4. Staying in the System Preferences->Network pane, at the top of that pane is the 'Location' pull-down. Use that to select 'EditLocations …' and in the pop-out click on the + symbol to add a new custom named Location (calling it what you like) and then saving that in the pop-out, Network main page. Don't worry because it will act the same as 'Automatic', you just giving it a custom name. Then Use the System Preferences->Network pane, Airport card to rejoin your wireless network.


    5. Turn off the wireless card. Then open Finder window and go to the folder /Library/Preferences/SystemConfiguration/ and move the files com.apple.airport.preferences.plist & NetworkInterfaces.plist to your desktop. Then IMMEDIATELY REBOOT!!!


    This reboot will rebuild fresh Preferences in that folder. Upon the reboot go back into System Preferences->Network page and male sure all you networking devices are put back in. If any are missing network port you can use the + button, in the Network System Preferences pane, and add the port back into your Macs Network setup. Then from that pane select you Airport card and from there use that Network pane to rejoin your wireless network. Lastly if everything is working, throw out those files you moved to the desktop out.


    6. In your wireless router go back to System Preferences->Network pane and click on the 'Advanced' button, Hardware ini-tab and set your MTU settings back down from 1500 to 1453. Some older wireless routers seem not to be able to do Jumbo frames (the 1500 MTU settings). It is hit or miss in the hint.


    7. Reset your wireless router. If you never been in your wireless router, get the default router password visit the web site Router Passwords.com to get the default username/password. This way you can reset your wireless router.
     
  3. chadnikk thread starter macrumors newbie

    Joined:
    Jul 20, 2014
    #3
    Wow! Thank you sooooo much for your help! That seems to have done the trick! I really really appreciate the help. I have been struggling with this issue for a couple months now and am thankful for your help! You are a lifesaver.

    Cheers!

    Chad
    :D:D:D
     

Share This Page